TechSpot

Computer fails to start

By McGod
Mar 14, 2007
  1. Went to plug in a USB Jump Drive and it shutdown, thought i knocked the power cord out and didn't start up. I noticed that when I hit the switch on the back of the PSU it made a weird noise and it smells as if it fried. So I bought a new PSU and it still doesn't work. I've tried
    (1)Stripping all the cards and trying just the Cord
    (2)Resetting CMOS
    (3)Cleaning some dust etc..
    (4)Checked CPU for any irregularities

    It won't start anything, No fans, drives etc.. I'm thinking the old PSU fried the Mobo:/ Any tips before I go spend another $100's on a Mobo?
    -AsRock K8Upgrade-VM800 Mobo(754 Pin)
    -512MB Cosair
    -AMD Seperon (Not sure of speed)
    -ATI Radeon 7500
     
  2. Tedster

    Tedster Techspot old timer..... Posts: 6,000   +15

    doesn't sound good my friend..... you just have to keep troubleshooting by swapping out parts. Strip to the bare minimum on a piece of cardboard and try to boot from there.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...