Computer won't load BIOS! Stuck at POST screen! I am clueless ;(

By BioManiacal
Jul 12, 2005
  1. Within the past week, my computer kept randomly rebooting, and eventually stopped turning on at all, so I bought a new PSU, and now it boots, but only to the POST screen, I try to press F2 to load the BIOS, but it does nothing. I also tried changing the jumper to boot into the BIOS setup, but it still stuck on the POST screen, but says "setup loading" instead of "press <F2> to enter BIOS setup" I am completely lost and have swapped out and checked the PSU, RAM, GPU and CPU. I am afraid it is a motherboard or HDD problem. Anyone have any ideas? Thanks for your help!

    (Also, there are no beep errors, of course! >_< )
  2. Superczar

    Superczar TS Rookie

    Most probably, this is a HDD issue....Try this to verify:

    - Take out the HDD IDE cable
    - Switch on the PC..keep hitting DEL till it takes you the BIOS Stup screen...

    If you can reach the BIOS Setup, it most prolly is a HDD issue....
    Jyust to verify, you may want to try booting from aCD ROM if the above works
  3. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Your computer hangs during POST.. The reasons may be bad RAM, bad CPU, bad video card, bad motherboard, bad keyboard, bad PSU, bad drives bad whatever you have connected :p

    Try booting and entering BIOS setup with nothing else plugged to your computer but the monitor and keyboard. Disconnect all drives and add-in cards. If you have several memory sticks then try with only one at a time.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...