TechSpot

Computer wont start, power supply wont start, blinking led

By Gullytiger
Oct 29, 2007
Topic Status:
Not open for further replies.
  1. So I turn my computer off one day only to find it wont start the next day. I open the case up and see the led is on. I flip the switch on the power supply off then on and quickly press the power button. My computer starts but the following time I shut down the computer it again wont start and now the led is blinking. I've never had any issues like this before, any help would be appreciated.

    I don't routinely use many usb devices, only my mouse and keyboard and every now and then my ipod. I figure the issue is likely either the power supply or the motherboard. The ps is almost two years old while the motherboard is only about three months old.
  2. aspirulito

    aspirulito TS Rookie Posts: 51

    It sounds to me like your PSU is the problem, get a hold of another and plug it to your computer and see if that will make it start, if it doesn't it might be BOTH your motherboard and PSU. A bad PSU will burn a motherboard.
  3. Tedster

    Tedster Techspot old timer..... Posts: 10,074   +13

  4. Smartmike

    Smartmike TS Rookie Posts: 65

    I had a similar problem once. Try disconnecting the the power supply from the mother board and reconnect it, If that doesn't work try disconnecting and reconnecting the switch. Be sure to place the switch EXACTLY the way it was.
  5. drexen

    drexen TS Rookie

    PowerLED blinking, everything else seems dead

    Hi,
    Im having the very same problem, and Im getting pretty desperate now...

    I turned off my pc one day, and after the shutdown the PSU started buzzing and the PowerLED were flashing (abt 2 times a second). I assumed it was the PSU that had died and bought a brand new PSU, installed it and NOTHING! PowerLED still blinks as before (though no buzz from PSU), PSU fan is not rotating either.

    Today I got my new motherboard and a new chassis. Put it all together and powered on... and guess what? Blinking PowerLED and NOTHING !!!

    My PSU is at 600w and should be more then sufficient. Ive tried stripping the PC from all but the PSU and motherboard (with cpu and memory of course). But still the same.. PowerLED blinks, but nothing happens..

    Usually when the CPU or memory has defects you should get a beep-beep-beep alarm from the motherboard i believe.. ?? Have had that happen to me before when a CPU died..

    Can a faulty CPU be the cause of this?? Or am I wasting even more money by buying a new CPU? Anyone?
  6. Tedster

    Tedster Techspot old timer..... Posts: 10,074   +13

    replace the bad psu
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.