TechSpot

Confused and lost (severe graphic problems)

By crotchy
Jul 2, 2010
Topic Status:
Not open for further replies.
  1. Hi...
    I have a problem with (as far as i can see) my graphics.

    It starts with the flickering screen every time i try to run either Call of duty MW or Battlefield Bad Company 2. In Cod the screen flickers just as the map starts and it last for 10-15 seconds before it levels out. This happens every time a new map loads.
    Now...in BBC2 however the problem gets worse. I had the same problem here,but lately the game has started to freeze up on me resulting in a completely no access situation for me (i have to manually shut down the computer).
    All other functions work just fine (web browsing,other programs etc..)
    Here's my specs:

    Asus p5q motherboard with Intel eaglelake p45 chipset
    Bios: ami (07/31/08)
    Quadcore Intel core 2 Quad q6600 cpu
    ddr2-800 sdram (4x1024)
    Ati Radeon 4850 HD 512 mb running with DX11
    Monitor: Dell slimthroat 19" crt generic pnp

    First i tried all the normal stuff: Dusting,checking the cables,upgrading the display drivers etc...with no effect.
    I did a memory test using memtest 86. Everything was fine.
    I did a stress test with Everest:

    cpu core: 1,24
    +3,3v: 3,33
    +5v: 5,11
    +12v: 12,04
    In the end i thought i'd try a graphic stress test using 3D mark. Now the irony here is that after about 10 seconds into the test the screen started flickering again and guess what...it turned all black,froze up on me,and i once again i had to manually shut down the computer:-/

    I'm kind of lost as to what the problem could be. Does anyone recognize this or have a clue as to what my problem might be?

    Note: I should mention that when using Sony vegas the rendering of a project seems to create the same problems and when using Particle Illusion i get it too (almost as bad as when playing BBC2)
  2. Ritwik7

    Ritwik7 TechSpot Chancellor Posts: 2,288   +7

    What PSU are you using? For how long have you been experiencing these issues?

    The HD 4850 is not DX11 capable.
  3. crotchy

    crotchy TS Rookie Topic Starter Posts: 19

    yes i typed it wrong:-/
    It's Gainward Radeon HD 4850 512mb gddr 3 running with dx10.
    The psu i'm using is a Corsair VX 550W ATX 12V V2.2,80 Plus,Standard,1x 6pin,1x 6+2-pin PCIe,6x SATA,120mm fan.
    The problem as it was when running Vegas,Particle Illusion and Cod has been present for at least a year or so. At first the problem was the same when playing BBC2. But it got worse three days ago.
  4. Ritwik7

    Ritwik7 TechSpot Chancellor Posts: 2,288   +7

    Did you have these problems right from the instant that you bought / assembled the system?

    I suggest that you test the video card on a different machine if possible and see if the problems occur there.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.