TechSpot

Confusing Network issues

By British_Command
Dec 9, 2006
  1. So heres my problem, i have 2 laptops which both have wireless adapters, i also own a Linksys WRT54GS internet router. One of my laptops works fine wirelessly, but my other Packard Bell laptop has to be connected to the laptop to work via ethernet cable plugged into one of the ports in the back of the internet router to work!

    Whenever i unplug it i cannot go online! even know my internet adapter is picking up and connecting to a wireless connection which is mine! Its fairly confusing and i have forgotten my details to the configuration page for the router although i can try and remember them.

    ANy help appreciated,
    Thanks for any info.

    Tom Wells-Day
     
  2. Rick

    Rick TechSpot Staff Posts: 4,573   +65

    Perhaps you could paste an ipconfig /all here. Do this for both computers.

    Start > Run > cmd

    In the cmd window, type ipconfig /all. Right click on the title bar of the cmd window and click on "Edit" and "Select All". Right click anywhere on the highlighted text in the window and this will copy the information. Paste results from both computers here.
     
  3. British_Command

    British_Command TS Enthusiast Topic Starter Posts: 148

    Packard Bell

    This is the packard bell laptop, the laptop that has to be connected to access the internet :

    Microsoft Windows XP [Version 5.1.2600]
    (C) Copyright 1985-2001 Microsoft Corp.

    C:\Documents and Settings\Jo>^V
    '▬' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Documents and Settings\Jo>ipconfig /all

    Windows IP Configuration

    Host Name . . . . . . . . . . . . : Baby-Belle
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Unknown
    IP Routing Enabled. . . . . . . . : Yes
    WINS Proxy Enabled. . . . . . . . : No

    Ethernet adapter Local Area Connection:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Realtek RTL8139/810x Family Fast Eth
    ernet NIC
    Physical Address. . . . . . . . . : 00-C0-9F-BF-06-76
    Dhcp Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    IP Address. . . . . . . . . . . . : 192.168.1.100
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . : 192.168.1.1
    DHCP Server . . . . . . . . . . . : 192.168.1.1
    DNS Servers . . . . . . . . . . . : 194.168.4.100
    194.168.8.100
    Lease Obtained. . . . . . . . . . : 09 December 2006 18:03:53
    Lease Expires . . . . . . . . . . : 10 December 2006 18:03:53

    Ethernet adapter Wireless Network Connection:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Intel(R) PRO/Wireless 2200BG Network
    Connection
    Physical Address. . . . . . . . . : 00-13-CE-35-DD-44
    Dhcp Enabled. . . . . . . . . . . : No
    IP Address. . . . . . . . . . . . : 192.168.0.1
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . :

    C:\Documents and Settings\Jo>
     
  4. British_Command

    British_Command TS Enthusiast Topic Starter Posts: 148

    This...

    This is the laptop that works:

    Microsoft Windows XP [Version 5.1.2600]
    (C) Copyright 1985-2001 Microsoft Corp.

    C:\Documents and Settings\Victoria Hamilton>ipconfig /all

    Windows IP Configuration

    Host Name . . . . . . . . . . . . : PC927049201245
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Mixed
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No

    Ethernet adapter Wireless Network Connection 2:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Broadcom 802.11b/g WLAN
    Physical Address. . . . . . . . . : 00-14-A5-B4-84-C6
    Dhcp Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    IP Address. . . . . . . . . . . . : 192.168.1.102
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . : 192.168.1.1
    DHCP Server . . . . . . . . . . . : 192.168.1.1
    DNS Servers . . . . . . . . . . . : 194.168.4.100
    194.168.8.100
    Lease Obtained. . . . . . . . . . : 09 December 2006 18:17:16
    Lease Expires . . . . . . . . . . : 10 December 2006 18:17:16

    Ethernet adapter Local Area Connection:

    Media State . . . . . . . . . . . : Media disconnected
    Description . . . . . . . . . . . : Intel(R) PRO/100 VE Network Connecti
    on
    Physical Address. . . . . . . . . : 00-16-D4-33-7D-8E

    C:\Documents and Settings\Victoria Hamilton>
     
  5. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    I would try this,disable dhcp in router and set wireless to static
    disable the onboard network
    use the wireless
     
  6. British_Command

    British_Command TS Enthusiast Topic Starter Posts: 148

    Will do!

    Will do mate, i will tell you what happens...
     
  7. British_Command

    British_Command TS Enthusiast Topic Starter Posts: 148

    Nope

    Npe, didnt work mate, Thanks for that know :D
     
  8. Rick

    Rick TechSpot Staff Posts: 4,573   +65

    The problem is you have ICS enabled (Internet Connection Sharing) on the laptop's wireless connection.

    Your wireless adpater has an IP address of 192.168.0.1 and DHCP is disabled, which is a pretty good give away. What's happening is your laptop is attempting to share Internet through its wireless adapter. This is confusing the other computer.

    Go to Start > Run > ncpa.cpl

    Right click on your Wireless Connection icons, click 'Properties, 'Advanced' and disable ICS (Internet Connection Sharing).

    To be certain, restart both computers and things should be back to normal again.
     
  9. British_Command

    British_Command TS Enthusiast Topic Starter Posts: 148

    Nope..

    The ICS disabling didnt work! Infact i cant even find where ICS is! I had to do it using regedit. Also it made my internet stop working!

    Anyways im back to square one, anymore possible solutions?

    Thanks
     
  10. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    when doing static did you use the WAN ip address's that should be in the status box of router

    they will not be a local address
    disable simple file sharing may help

    the DNS servers should be those WAN ip numbers
     
  11. British_Command

    British_Command TS Enthusiast Topic Starter Posts: 148

    Ok

    Ok i will try that im sure the ip of the static was 192.168.1.1 but should be my WAN's so it would be 192.168.0.1? I think so anyways but i will have try, thanks again
     
  12. Rick

    Rick TechSpot Staff Posts: 4,573   +65

    Your WAN will never have an address of 192.168.xxx.xxx, this is reserved for private networks (LAN) only. Your LAN IP should be 192.168.1.xxx by default, since this is the common IP block for Linksys.
    This IP address is the address of your router and should not be used for any other network equipment on your LAN.

    Your IP config looks great, except for the above. Set your wireless to DHCP and connect to your linksys router. What happens? Do you get an IP address? If so, what is it? Also, what are you gateway and DNS IPs for your wireless?

    Your wireless card should never have an IP of 192.168.0.1 unless you are sharing your Internet through your laptop (which isn't the case, I hope ;)). 192.168.0.1 is typically an address for a router, but not Linksys. Linksys has always been 192.168.1.1. The only reason you're laptop would have an IP like this is if were set manually, so change it to DHCP.
     
  13. British_Command

    British_Command TS Enthusiast Topic Starter Posts: 148

    it was

    it was set to DHCP auto first of all, all know this isnt my laptop issue its actually a relative, is it possible she has setup the network to share through her laptop and not wirelessly?

    As you said 'i hope this is not the case' which i think could be the 'case', if thats possible would it only need re-installing?
     
  14. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    its possible
    XP loves to take command as domain server one way or another
    as stated disable ICS
    and static WAN is listed in the router status page
    DNS Servers . . . . . . . . . . . : 194.168.4.100
    194.168.8.100
    proxy server DNS???? NTL

    sometimes the default 4.2.2.2 and 4.2.2.3 for WAN will work
    flush DNS

    start/run /cmd / (type-->> ) ipconfig /flushdns
     
  15. British_Command

    British_Command TS Enthusiast Topic Starter Posts: 148

    So...

    So I think im going to reset the whole router

    Then i will go from there...

    i will also do the flushdns...

    If there is any more help i would be willing to try anything...
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...