TechSpot

Connecting MacBook Pro to a PC workgroup

By Gouge
Feb 17, 2012
Post New Reply
  1. I have just bought a Macbook Pro running OS 10.7.3 Lion.

    I want to connect it to an existing PC workgroup via my Belkin wireless router. I have successfully accessed the internet on the Macbook via the router, but I am unable to connect it successfully to the workgroup.

    I have done everything mentioned on previous threads - the latest for a Mac runnimg Leopard - but still won't connect.

    I can see the icon for the Macbook on my PC workgroup page, but when I double click the icon I get the error message:
    \\Macbookpro-2098 is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permission

    The network path was not found.
    :mad:

    I have an old Windows Laptop connected by ethernet cable directly to the router and that is able to see the Macbook documents. However I can't see either the PC or Laptop on the Macbook.

    The PC and laptop are running Windows XP.

    I'm not sure where to go from here!!:(
     
  2. jobeard

    jobeard TS Ambassador Posts: 13,446   +324

    Both systems need the SAME user login.

    When sharing a Mac resource with Windows, the Mac needs your Windows Login
    and when sharing a Windows resource, the converse.
     
  3. SNGX1275

    SNGX1275 TS Forces Special Posts: 12,626   +320

    I'm not sure they do jobeard.

    Open the Sharing panel in System Preferences and check File Sharing and then click on Options... Check share files via SMB.

    Edit. I can't seem to make that work on a Lion system. I can see it on the Network from within Windows 7, but when I connect it prompts for user and pass. I enter those correctly (for the account I want to use on the Lion system) and it says invalid credentials. I guess this is because it wants to use \WIN7COMPNAME\MACUSERNAME to connect rather than just MACUSERNAME. Interestingly though, I've got a Powerbook running 10.5 that I connect to from several different Windows 7 machines and have no problem. It appears I have the settings the same between 10.5 and 10.7 but perhaps I don't.
     
  4. jobeard

    jobeard TS Ambassador Posts: 13,446   +324

    Granted, both my Mac & Windows systems are down level and Win/7 has made changes - -
    BUT, once upon a time (Mac 10.3 & XP/Pro SP2) this works.
     
  5. jobeard

    jobeard TS Ambassador Posts: 13,446   +324

    Yes, that's how I access Mac 10.3 eg: run->\\systemName\userName.
    However, my systems have constant IPs and names entered into etc\hosts, so on other systems
    you may need to use \\systemIPaddress\userName

    Not using Simple Sharing, I then need the Mac User's password (which can be different than the Windows password for the same user).
     
  6. SNGX1275

    SNGX1275 TS Forces Special Posts: 12,626   +320

    From a Windows 7 machine, I can see "MINI", Mini runs 10.7. When I double click it it wants user pass. I enter 'David' for user, and then my password that is the password for 'David' on the Mini. It comes back with invalid credentials. I suspected that this is because the Windows 7 machine now has autofilled (and it is unchangable) the username to WIN7PC\David and has me enter the password. So I suspect the Mac is seeing this as "WIN7PC\David" rather than just "David".

    Although, if that is correct, why can I connect to the Powerbook without this happening? There may be some differences in the Sharing (preference pane) that I'm not immediately noticing.

    This behavior is consistent between at least 3 different Windows 7 machines. They all connect to the Powerbook fine, all exhibit the same User Pass behavior outlined above when connecting to the Mini.

    Update: Interestingly though, the Mini has a 1 name username, 'David'. My MBP has my full name, and the powerbook's is my girlfriend's full name. I can connect to my MBP from a Win 7 machine by entering my full name for the username, and then entering the password. The Windows 7 machine does not have my full name, nor the same password as my MBP.

    Seems odd that having a 1 name username allowing sharing on the Macs would prevent Windows 7 from connecting, but that is the only common thing I've found so far by checking through the Sharing preference pane settings.
     
  7. jobeard

    jobeard TS Ambassador Posts: 13,446   +324

    I should make a clarification: run-> \\systemName\userName is the Windows access to the Mac user

    Mac access is smb://systemName/shareName and then there's a prompt for user/password (as known on windows)
     
  8. jobeard

    jobeard TS Ambassador Posts: 13,446   +324

    My understanding is the pair "WIN7PC\David" gets parsed into
    two tokens: WIN7PC & David, the former being used for system-name->ip-lookup and the latter as the user-id to be accessed.

    what occurs when you
    ping WIN7PC
    vs
    ping WIN7
    vs
    ping macName
     
  9. SNGX1275

    SNGX1275 TS Forces Special Posts: 12,626   +320

    Typing it in manually, to the Mini still doesn't work. ie - \\MINI\David It presents the exact same way as clicking on MINI in the browse Network window.
     
  10. jobeard

    jobeard TS Ambassador Posts: 13,446   +324

    smb access has always been 'caseless', but perhaps Win/7 is sending the UID
    as typed, so try all upper, eg DAVID or all lower david

    Usually in a given protocol (ftp, telnet, ssh, http) the sender is responsible to send
    data correctly. At least on Mac 10.3 & Win/XP, the case doesn't matter regardless
    which system is sending.
     
  11. Gouge

    Gouge TS Enthusiast Topic Starter Posts: 128

    All very interesting and encouraging to know that others share my problem, but it hasn't helped me in the slightest!!!

    Can you explain what I need to do in simple terms.

    My PC has only one account with no login password - I just boot it up and away I go. It is protected by ESET NOD32 and the Windows firewall.
     
     
  12. jobeard

    jobeard TS Ambassador Posts: 13,446   +324

    just remembered an OLD issue for hetrogeneous system sharing
    SMB V2 was deadly (ie not usable) for Mac's & Linux - - you have to force V1

    For the key
    HKLM\System\CurrentControlSet\Control\Lsa\LmCompatibilityLevel

    set value of 1 ; Send LM & NTLM - use NTLMv2 session security if negotiated
    then reboot windows

    This will allow Mac OS X & Linux systems to share both ways with Windows systems.

    see also https://support.apple.com/kb/HT1568
     
  13. Gouge

    Gouge TS Enthusiast Topic Starter Posts: 128

    I don't have a "Local Security Policy" option in Administrative Tools!!

    I couldn't find a path to Local Policies - Security Options
     
  14. SNGX1275

    SNGX1275 TS Forces Special Posts: 12,626   +320

    Yeh, sorry about hijacking your thread, that wasn't my intention it just sort of happened.

    Can you check, on your MBP, what the Sharing settings are in the Sharing preference pane? (Apple Menu, System Preferences, Sharing).

    On my MBP (Which is connectable from any Windows 7 machine on my network) I have File Sharing checked. Then I have folders I want shared choosen and permissions set. Then click Options. Make sure Share Files and Folders using SMB (Windows). Then you need to check the right username (if only 1 then check that) and enter your password.

    Also, you may want to go to the Network preference pane and select the connection you are using. Then click the Advanced button. Then go to the WINS tab. You should set the workgroup there (or verify its correct if your windows machine's workgroup is 'WORKGROUP'). I do not know how necessary that step is, but its certainly not going to hurt.

    Now, most of the time not all my Mac computers show up on Windows when I open up Network on Windows. So try to get to them by using their IP (ie. \\192.168.1.whatever). Once you do that and log in, that Mac should show up in Network (at least until you restart). So what I have done is make a shortcut to the computer so I don't have any problems getting to it again.



    Now going from Mac to Windows, they also sometimes don't show up in the Mac sidebar. So I use the Go menu at top and select 'connect to server' and then type in SMB:\\Win7 (use whatever your PC's network name is). You can also click the "+" in that window so you don't have to type it in every time.
     
  15. jobeard

    jobeard TS Ambassador Posts: 13,446   +324

  16. jobeard

    jobeard TS Ambassador Posts: 13,446   +324

  17. Gouge

    Gouge TS Enthusiast Topic Starter Posts: 128

    Er.... OK. I appreciate the responses, but I'm afraid that I'm not an IT expert and there are some major gaps in my understanding here!!!

    I can follow what SNGX1275 has suggested, but not sure about your suggestions jobeard.

    Please keep it simple!!
     
  18. Gouge

    Gouge TS Enthusiast Topic Starter Posts: 128

    I ran gpedit as suggested, jobeard, but got the answer "MMC could not create the snapin" whatever that means!!

    I also installed XPadmSetup.msi
     
  19. Gouge

    Gouge TS Enthusiast Topic Starter Posts: 128

    SNGX1275 - my Share settings are File sharing and Printer Sharing and I've got all of the files/documents included with "Read only" set for Everyone.

    Share files and folders using SMB is checked (...using AFP is not checked). Only one username and that's checked.

    WORKGROUP is the common group name there, but there are no WINS servers listed.

    Now, most of the time not all my Mac computers show up on Windows when I open up Network on Windows. So try to get to them by using their IP (ie. \\192.168.1.whatever). Once you do that and log in, that Mac should show up in Network (at least until you restart). So what I have done is make a shortcut to the computer so I don't have any problems getting to it again.

    Where do I enter the computer IP in Windows? Tried it in my browser and it said server cannot be found. How do I then do a shortcut? Highlight - copy and paste the icon when it appears?

    Tried to connect to the XP PC but it said there was a problem connecting.
     
  20. jobeard

    jobeard TS Ambassador Posts: 13,446   +324

    permission issue.
    DISABLE UAC and login as the Administrator
     
  21. Gouge

    Gouge TS Enthusiast Topic Starter Posts: 128

    More info:

    I connected my Macbook to the router with an ethernet cable, set up the ethernet connection and guess what?? I can see my PC and its shared files on the Mac and I can see the Mac shared files on the PC.

    The PC is still a wireless connection.

    Could it be a problem with the settings on my Belkin router?

    It's a Belkin Wireless G - F5D9630-4A

    Thinking back, I did have problems linking my Windows Laptop wirelessly. I had to use an ethernet link then.
     
  22. Gouge

    Gouge TS Enthusiast Topic Starter Posts: 128

    I'm on Windows XP. UAC was introduced on Vista and W7 I understand.
     
  23. Gouge

    Gouge TS Enthusiast Topic Starter Posts: 128

    As I've had no further replies from this forum, I searched through other forums and advise sites and found the solution.

    I had to enable SMB (SAMBA) on my Windows devices as that's the protocol used by Mac OSX Lion. I also had to disable the firewall on my wireless router modem.

    The connections aren't brilliant - keep on losing connection, even with broadband internet - so I'm thinking of replacing the Belkin with a Wireless N router.
     
  24. SNGX1275

    SNGX1275 TS Forces Special Posts: 12,626   +320

    Thanks for the update, but thats odd you had to enable samba on Windows. I may have done that on one of my Windows machines, but I certainly haven't done it on all of them, and I can get in. Maybe just simply turning on file sharing on the Windows machines does that automatically?
     
  25. jobeard

    jobeard TS Ambassador Posts: 13,446   +324

    me too. SMB sharing (vs netbios on UDP ports137,138) uses TCP port 445,
    so the firewall plays a part here.

    also noted:
    just remembered an OLD issue for hetrogeneous system sharing
    SMB V2 was deadly (ie not usable) for Mac's & Linux - - you have to force V1

    For the key
    HKLM\System\CurrentControlSet\Control\Lsa\LmCompatibilityLevel
    set value of 1 ; Send LM & NTLM - use NTLMv2 session security if negotiated

    This will allow Mac OS X & Linux systems to share both ways with Windows systems.

    see also https://support.apple.com/kb/HT1568
     


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.