Counter-Strike Source connection problems

By impulse7
Mar 21, 2006
Topic Status:
Not open for further replies.
  1. I've been playing Source on my new computer for almost a month now and lately I've been having devastating connection issues. After about 5 to 10 minutes of play on a public server, my connection will just time out on me for no reason. No one on the server experiences this problem either. I'm not downloading anything in the background and haven't changed my network settings. I used a Linksys wireless-G router and my computer is in the same room as the router. Has anyone experienced this or know what the problem could be?
  2. Akifuddin

    Akifuddin Newcomer, in training Posts: 150

    Same problem with me (In every game and even internet surfing) but sometimes, it stops for a while but comes back some day.
  3. impulse7

    impulse7 Newcomer, in training Topic Starter

    I've been on the phone with my local broadband provider and the problem doesn't seem to be on their side. The modem is working fine and has 99% uptime.

    I have a Linksys VOIP router connected to the Modem and then a Linksys Wireless-G connected to the VOIP router. I'm going to test my connection directly to the modem and then to the VOIP router and finally the wireless router. Which ever connection fails me will determine which device is to blame.
  4. lewekleonek

    lewekleonek Newcomer, in training Posts: 59

    There seems to be a known problem with Steam client and Valve games caused by Linksys routers.
    Add this parameter to each game you're playing: CS: Source, DOD: Source etc.
    Right click on the game, select Properties from the context menu. Once in properties window click on [Set launch options...] button.
    Launch options window will appear. Enter the following value:
    +clientport 27006
    Save it.
    Now it should work...
  5. impulse7

    impulse7 Newcomer, in training Topic Starter

    How did you know about that?
    I bought a new Linksys SRX200 router and I'm still having this problem.
    I'll try your suggestion and let you know if it works. Thanks!
  6. fimbles

    fimbles TechSpot Evangelist Posts: 1,198   +105

    oh joy..

    I just got a linksys router... :mad:
  7. lewekleonek

    lewekleonek Newcomer, in training Posts: 59

    It's been a long known problem with BEFSR41. I don't know about SRX200. Linksys routers are not that bad. Actually WRTG54 (the wireless one) flashed with good aftermarket firmware works like a charm, I've heard.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.