Damaged Mobo? Damaged CPU? Or something else...?

By Kr0ft
May 8, 2006
  1. Right..
    My pc suddenly switched off 2 days ago and never switched on again. I have been testing the system compnents since then with some spare compnents that I have. Here are the facts:
    Power Supply doesn't seem to work at all although when connected to the motherboard the light on the mobo switches on.
    Moterboard works when CPU is missing.
    CPU & PSU fans are clean.
    I dont know if I should check something else so I am open to suggestions.

    Details of the system.
    1 GB RAM
    Pentium 4 @ 2GHz
    Radeon SE9600
    Mainboard ASUS P4P800-E Deluxe
    160 Gb Maxtor 10

    Any help will be much apppreciated
  2. theholmboy

    theholmboy TS Rookie

    Instantly dying computer = PSU death

    Don't let the light on the motherboard throw you off, since it is very likely a dead PSU. Fortunately, it's one of the cheapest things to replace, unless you have some oddball PC case that requires a special sized PSU. Hopefully you just have a standard ATX power supply to replace - swap it out with a known working spare or buy a replacement and try that first. Check back if that doesn't fix it.

    Out of curiosity, what do you mean when you say "Moterboard works when CPU is missing." I have yet to run into a motherboard that does much of anything without a CPU installed. ;)

  3. Jaquio

    Jaquio TS Rookie Posts: 26

    mmm... just to check... when you put the CPU on the MOBO... do you connect the separate CPU power plug from the PSU to the MOBO?

    Regards from Panama...
  4. Kr0ft

    Kr0ft TS Rookie Topic Starter

    Problem solved

    Problem solved.. It was the PSU!! Thank you guys
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...