Dealay on showing 'My Computer' Information

By tuant
Feb 2, 2008
  1. Hi
    I have this problem which is often very annoying. Theres is about 10 sec delay when I try to open 'My Computer'. I not talking to abut the OS, this is for the icon on the desktop. The 'My Computer' window will open however all the drive information are slow to load/show. Any suggestions?​
  2. mscrx

    mscrx TS Rookie Posts: 310

    can you provide more information please?
    do you use network drives for example? or do you have discs in the your optical drives? what sort of computer is it, specs maybe?
  3. tuant

    tuant TS Enthusiast Topic Starter Posts: 200

    No, I don't have any network drives nor are there any discs in my optical drives.

    Computer specs:

    Abit IP35 Pro
    Intel Q6600
    4GB Patriot DDR2 PC2-6400
    320GB HD (For OS, Windows XP Pro)
    500GB HD (For Data)
    Saphire HD3850 512mb DDR3
    Modular 630Watt Power Supply

    I think that should do it
  4. jobeard

    jobeard TS Ambassador Posts: 9,156   +598

    dbl click any folder to open it
    use Tools->Folder Options
    click the View Tab
    uncheck the following:
    Search for network folders and printers
    Display file size ​
  5. tuant

    tuant TS Enthusiast Topic Starter Posts: 200

    Thanks for the tip, this did increase the loading process however not completely. There is still a delay and it appears to be gathering information. This only occurs on the initial launch of 'My Computer'. Accessing folder/files from within 'My Compute' is almost instantaneous.
  6. gbhall

    gbhall TechSpot Chancellor Posts: 2,423   +77

    Anything plugged into your USB ports? Any printers or other things? Unplug 'em for testing. Have you unchecked 'allow remote assistance'?
  7. mscrx

    mscrx TS Rookie Posts: 310

    good advice! you could also run a defrag if you have alot of data on the disc it can get fragmented pretty fast.
  8. jobeard

    jobeard TS Ambassador Posts: 9,156   +598

    the delay is two fold:

    1 network access (both to connected and non-connected systems)
    2 getting fileinfo for every folder/file shown on the right pannel
    The USB access will only occur if it is connected, unlike Ethernet must make the access to find it missing.
  9. tuant

    tuant TS Enthusiast Topic Starter Posts: 200

    The only devices connected to the UBS are keyboard/mouse and external DVD-Rom which is rarely turn on. I've also defrag the drive twice to no avail and 'allow remote assistance' is also disable. Both of my drives are set up the same in terms of what is to be displayed when I open the drives, currently they include: 'Name', 'Size', 'Type', 'Date Modified'. I also removed all the attributes and still there is a delay. The odd thing is my 500GB (forgot the model) open instantly whereas the 320GB, for some reason, has a delay. If this is the case, I believe my boot time will greatly increase if I transfer my OS over to the 500GB drive.

    Drive Info: (The one with the issue)
    Western Digital
    WD Caviar RE16

    Drive Parameter:
  10. gbhall

    gbhall TechSpot Chancellor Posts: 2,423   +77

    Is the slow device compressed or encrypted?

    does the directory that the slow device opens on contain any zipped files? Those can cause horrendous delays, but there is a way to switch off the underlying unzip process.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...