TechSpot

Direct3D error - Radeon 9200 - Can't run ANY 3D games...Help?!

By tieflingmouse
Mar 8, 2005
  1. hi I started getting this problem as soon as i upgraded my motherboard & processor to a amd 64bit 2800+ on a k8m800 +8237 chipset board.

    Direct3D 7 test results: Failure at step 8 (Creating 3D Device): HRESULT = 0x80004005 (Generic failure)
    Direct3D 8 test results: Failure at step 8 (Creating 3D Device): HRESULT = 0x8876086c (error code)
    Direct3D 9 test results: Failure at step 8 (Creating 3D Device): HRESULT = 0x8876086c (error code)


    before i had a P3 750 Mhz with the same card and everything ran fine... now since i upgraded, i've had no problems with anything except for this damn directx error.

    I've reinstalled Directx 9.0c and 8.1, neither work...

    when i open world of warcraft or WC3:FT, my screen goes black like its about to start, then it closes the app and says: 'World of Warcraft was unable to start up 3D acceleration. Please make sure directx 9.0c is installed and your video drivers are up to date.'

    they are as far as i know and it still wont work...why was it working on a p3 750 and not on this new MB and processor? Help?

    ps: the driver version for my radeon 9200 is 6.14.10.6374
     
  2. vegasgmc

    vegasgmc TechSpot Chancellor Posts: 1,764

    Did you do a clean install of Windows when you changed motherboards?
     
  3. LNCPapa

    LNCPapa TS Special Forces Posts: 4,341   +280

    Are you familiar with modifying values in your registry? If so then take a look at
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\GraphicsDrivers\DCI
    You should see a Timeout value there - make sure the value is not 0. If it is change the value to 7 and reboot. I think that will fix your problem.
     
  4. tieflingmouse

    tieflingmouse TS Rookie Topic Starter

    yes, i did a clean install of Windows on my Master HD when installing my new motherboard. I checked the registry value as you suggested, and it is set to 7 like it should be...but nothing works still. The only way I can run 3d games is with the -opengl in the target, but they look crappy and lock up alot.

    I shouldn't have to do anything with my Storage Slave HD because of the new hardware right?
     
  5. celler_dweller

    celler_dweller TS Rookie

    radeon 9200

    im haveing the same problems with it not working but i think windows updates are to blame. iv had to format my comp 5 times in the last 2 weeks due to crashes and ever time i reinstall windows somthing new dose and dosent work. so it looks like maby try reinstalling windows and it might work(cant promise it will). im just gona do that now so ill let u know how it goes. :mad: :dead:
     
  6. walleteater

    walleteater TS Rookie

    :p

    i have radeon 9200 but it lets me play world of warcraft... even on high everything.... u probally need either : Microsoft Framework 1.1, Direct X v9.0c, or new ati upgrade..

    i can play wow... but it shuts off after a while asking me to restart my comp because of some vpu revory what not
     
  7. cracknugget2003

    cracknugget2003 TS Rookie

    did u try getting directx 9c ? it might help u out
    :) i hope it fixes ur prob
     
  8. C_Conqueror

    C_Conqueror TS Rookie Posts: 217

    I had a very similar problem so I was going to try to reinstall windows but couldn't for some reason (thats another storty) anyway all I did was repair windows using an xp cd and it fixed everything.
     
  9. vreg

    vreg TS Rookie Posts: 32

    directx 8.1 for xp?

    can you install directx 8.1 for xp i cant seem to find it
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.