TechSpot

DirectX Out of Memory Error

By Mr_Parker
Feb 20, 2002
  1. Hey guys....I recently began having problems with my video setup. I have a Geforce2 GTS, and the tv out quit working, and when I run Dxdiag, it wont run the direct3D tests, saying that

    "failed at step 8, HRESULT=800x7000e(out of memory)"

    and it recognizes the video card but where it says available memory, it just says n/a. I have reinstalled directX, tried 8.0 and 8.1, tried every available nVidia driver, it just all of the sudden happened. I am absolutely stuck. I have noticed other people have had this problem and they all seem to be running Windows 2000 like me. Any games that require Direct3D support, like NHL 2002 will not play. If anyone has any suggestions, I would greatly appreciate it. Thanks.
     
  2. Rick

    Rick TechSpot Staff Posts: 6,305   +52 Staff Member

    There isn't much else possible other than what you have already done to resolve this problem.

    Just as a suggestion, you should swing by www.ntcompatible.com and see if the games you are trying to play are indeed compatible with Windows 2000. This does not explain your dxdiag troubles though.

    Another thing to do is update your games to the latest versions by downloading any updates from your software devloper's sites.

    Lastly, apply the latest service pack (SP2) and fixes at www.windowsupdate.com .
     
  3. Phantasm66

    Phantasm66 TS Rookie Posts: 6,504   +6

    I surfed a little on the internet with your error message in mind.

    I am afraid, so far, the only thing I can work out is it looks like you have found a bug in Direct X itself. Some bug that, judging from your post, seems not to have been fixed yet.

    I am still looking....
     
  4. Mr_Parker

    Mr_Parker TS Rookie Topic Starter

    Thanks for looking....

    I appreciate the help....I am still looking as well, but I don't think there is an answer out there. I have three hdd's in my computer, so I am just going to install either XP or 98SE on one of them and dual-boot when I need Direct3D functionality. It sucks but it beats having to re-install 2000 and start over. What do you guys recommend, XP or 98SE??
     
  5. Phantasm66

    Phantasm66 TS Rookie Posts: 6,504   +6

    Re: Thanks for looking....

    Depends on system specs, but you should always run the newer OS unless your machine will not handle it, or there are specific problems, if nothing other than to save yourself from the hassle of installing patches and updates, etc.
     
  6. Mr_Parker

    Mr_Parker TS Rookie Topic Starter

    Okay.....

    now, I cannot install 98SE because I already have 2000 installed ( I don't know how to write the ARC path in the boot.ini well enough to make it work) and I cannot install XP because my SBLive! 5.1 wdm alpha driver gives me a stop error during the install! I have tried un-installing it and it still gives me grief. Does anyone know how I can install 98SE on another hdd and still dual boot?? I should be able to switch the empty hdd to IDE 0 and install there, and then add a path to the boot.ini that will point it to the 2000 installation on drive D: Is it possible to copy the ARC path that is there now for the 2000 OS and just change the disk numbers?? I know this is heavy but any suggestions, again, would be much appreciated. Thanks.
     
  7. rclenhardt

    rclenhardt TS Rookie

    if you downloaded dx 8.1 and recieved this error, you need to go into the dxdiag and disable then re-enable the d3d acceleration. this should clear up the error message.
     
  8. Mr_Parker

    Mr_Parker TS Rookie Topic Starter

    How?

    I have 8.1, and the AGP support and DirectDraw support say "not available" and when I click to disable Direct3D acceleration, it prompts to check yes or no to make sure, I click yes and nothing changes. It does not disable. And even if I can, how do you re-enable?? I don't think it would be something this easy, but maybe....................
     
  9. rclenhardt

    rclenhardt TS Rookie

    if the d3d acceleration is greyed out than it is possible that, with the new downloads you have been doing, the hardware acceleration has been turned down. to check that hardware acceleration is turned up:
    rt click on my computer->performance->graphics and be sure it is turned all the way up.
    to disable the d3d in dxdiag simply click on the enable button. it should then read disabled. to re-enable it simply click on the disabled button again.
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.