Driver problems, artifacts (GTX 560 Ti)

By snacks
Nov 22, 2011
Post New Reply
  1. It was fine a while ago, but I've come back after a month and this is pretty bad. I tried Crysis 2, there was something wrong with the game (a gray line coming out of the hands). This was after TF2 completely locked up the entire computer after about half an hour. I tried uninstalling the drivers and had the exe on the desktop. I restarted the computer and in safe mode, half of my icons were missing, including the driver exe. I tried running different drivers from folders and off a flash drive, every single install failed. I restarted the computer, and it booted normally to the desktop as if the drivers were still installed. It seemed fine, aside from Firefox locking up the entire computer. But I don't know what happened, and when I tried Mass Effect, there were blinking black squares everywhere.

    The GPU temp is low, 30 idle and maybe 60 when in a game. DX Diag and Device Manager say driver version is 6.14.0012.7533, not sure what that means. Presumably 275.33, as that's what the Mass Effect launcher said. Should I try updating my drivers? I don't know, seeing as how incredibly badly that went the last time. I need to figure out what went wrong.

    Asus P5G41T M LX
    Corsair XMS 4GB 240-Pin DDR3 SDRAM DDR3 1600 PC3 12800
    EVGA Geforce GTX 560 Ti 1024mb

    These are the updated specs, it's a mix of 3 year old parts and some pretty new parts, but it's been running fine for about 5 months until now.
  2. Jawshh

    Jawshh TechSpot Enthusiast Posts: 438

    Head over to nvidia.com and get the latest drivers.
  3. fimbles

    fimbles TechSpot Evangelist Posts: 1,226   +118



Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.