DVD Drive only works after system restart!

By tyleronline
Sep 24, 2006
Topic Status:
Not open for further replies.
  1. Hi there I have a very strange problem. If i start up my P.C and try to use the DVD drive then my computer will not recognise that there is any disk present nor will recognise the existence of the drive! If i restart my P.C with the disk still in then it works fine. Does anyone have any idea what the problem could be?
    Thanks

    Specs
    Carillon AC-1
    Intel 3.2 CPU
    1Gb Elixir Memory
    TSSCORP DVD RW Drive
    Asrock Mobo
  2. Steve

    Steve TechSpot Staff Posts: 1,284   +395 Staff Member

    Sounds like a buggy DVD player to me, have you tried using another DVD player? If another DVD player works fine then you have found the problem. I would certainly be starting with the player itself. Alternatively you can try the DVD player in another computer.
  3. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,646

    I needed a firmware upgrade to correct that.Make sure bios can see and recognize the drive. Make sure it is connected correctly.
  4. smore9648

    smore9648 Newcomer, in training Posts: 757

    Are the jumpers setup correctly to slave?
    Is the power connection properly seated?
    Are the drivers loaded correctly?
    Have you updated your firmware?
  5. tyleronline

    tyleronline Newcomer, in training Topic Starter Posts: 93

    Hi guys thanks for all the repsonses so far. I haven't tried the drive in another I shall try and test this. Also I shall update the firmware and reinstall drivers if i can find them. The drive used to work fine and i havnt changed any jumper settings since then. I will try your suggestions and get back to you!

    Thanks
  6. tyleronline

    tyleronline Newcomer, in training Topic Starter Posts: 93

    O.k I have reinstalled the firmware as I did have the latest version and that seems to have done the trick! I am still non the wiser as to how it helped though as it said i allready had the latest Firmware version? Oh well as ling as its works i suppose. Thanks for all your help and suggedtions guys!
  7. tyleronline

    tyleronline Newcomer, in training Topic Starter Posts: 93

    Ok its gone again i will turn on the p.c and now nothing. The drive doesn't show at all! It only shows itself after a few restarts. Does anyone know what the problem could be? This is driving me crazy!
  8. tyleronline

    tyleronline Newcomer, in training Topic Starter Posts: 93

    bump. still need help the problem seems to be getting worse!
  9. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,646

    Change the Drive letter for that DVD to a letter near the end of the Alphabet I use "V" for mine.
    Windows sometimes gets confused especially if you use USB peripherials, Camera , external drive etc. or if you Map drives etc.
    Let us know what happens
  10. tyleronline

    tyleronline Newcomer, in training Topic Starter Posts: 93

    ok i reseated all of the connections and it seems to fine now! sorry about that just me being silly again. althought the problem did return last time so I shall keep an eye out for any change. thanks for all, your help guys!
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.