TechSpot

explorer uses 95-100% cpu.

By Refwhett
Jan 15, 2003
  1. Lately my system just slows down horribly every once in a while.
    I looked in task manager and windows explorer was happily using all my cpu and most of my ram.
    I've noticed that it often happens after I access a specific partition and play around with some files there (mostly avi's and mpeg's) I know that the partition is often fragmented but I also defragment it often.
    I'm not sure if it's that, or what? anyway it doesn't sound right that explorer will use that much cpu just because the partion is a bit fragmented.

    Any ideas? I have to end explorer and restart it everytime if happens.------->rather annyoing.
     
  2. Vehementi

    Vehementi TechSpot Paladin Posts: 2,704

    Try setting the priority to 'low'.

    That happens sometimes with me - not often, it's been awhile. It's usually when I'm messing around in my 40GB partition - with big files like you. What's your file system? Mine's NTFS.

    Could be drive indexing or something like that...
     
  3. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    When you select a .avi or .mpeg file in Explorer, it will load the file in memory to present you with a thumbnail/preview when needed. If the file happens to be big, it will take a long time and a lot of resources. You won't be able to delete/move/rename the file during this activity either.

    You can disable the .avi file handler in registry, but beware - you'll also lose the ability to see clip properties in the properties window.

    Here's how you do it:

    1. Open up regedit
    2. Goto HKEY_CLASSES_ROOT\SystemFileAssociations\.avi\shellex\PropertyHandler
    3. Delete the "Default" value which should be "{87D62D94-71B3-4b9a-9489- 5FE6850DC73E}\InProcServer32"
     
  4. Refwhett

    Refwhett TS Rookie Topic Starter Posts: 71

    Well thanks Nodsu, I deleted that value and for now evrything seems great. wprks fast as lightning and btw I can still see previews and properties just like before.
    Does that make sense? I don't know, but for now it works.
    I have to long term test it though...
    Thanks :)
     
  5. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +7

    hey nodsu that's some not bad stuff.... :)

    the registry does move in mysterious ways....

    i have to remember that one thankz.....
     
  6. Refwhett

    Refwhett TS Rookie Topic Starter Posts: 71

    I just have to say thanks one more time. Not only is evrything fast and smooth but I can now also erase some filew that I couldn't before because xp said they are used by some other program when they weren't!

    All hail Nodsu!!!

    P.s
    How come that value is not different to begin with. What purpose was it supposed to serve? except jam the system...
     
  7. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    All components have global unique IDs in Windows. That value is the same because it's the same program in all XP distributions.
    I thought the purpose was I what I said before, but if you say previews and stuff still works.. Dunno.

    PS.
    I can't see clip properties after deleting it :(
    Maybe I should install AVI Info or sth?
     
  8. Refwhett

    Refwhett TS Rookie Topic Starter Posts: 71

    I acctually didn't have this part of the value \InProcServer32 only the numbers. Maybe that's the difference. I really don't know anything about this.
     
  9. poertner_1274

    poertner_1274 secroF laicepS topShceT Posts: 4,172

    Well either way, we are glad it helped you.
     
  10. CANHELP

    CANHELP TS Rookie

    XP EXPLORER 100%

    .AVI FILES ARE STILL IN USE EVEN AFTER REBOOTING

    I tried to find a fix for months... this is it
    usually you can't delete because these files are still in use

    slow performance then the whole desktop will refresh

    my response with a little more info is at the top the bottom is the basics

    http://www.annoyances.org/exec/forum/winxp/1083047032

    This is the one that has actually worked for me after a month or two of horrible performance. Just remember if there are spaces in the name you must put quotations around it. Also if the file is hidden it will not show up in the dir command. Try to highlight whole folder and then right click to change properties for all files at once or else you may never be able to get the properties up for the problem file. Use alt-a to select a large group of .avi files and try to delete them. the problem file will say it is in use by another program. there may be a few file so try it in groups. then restore the goo files out of you recycle bin. Also not inluded in original is after f8 you must go into safe mode with command prompt. I usally do not go on htese boards and reply but this is the one that actually worked for me after trying many.


    On Sunday, February 9, 2003 at 7:04 am, anonymous wrote:
    >
    >HOW TO GET WinXP BACK TO WORK PROPERLY
    >Every time you boot Windows normally, an Explorer process is started and then runs
    >invisibly in the background. Due to a bug, this process opens and reads continously
    >from certain avi files, causing the system to slow down and eating up more and more
    >RAM. Deleting these avi files is one way to solve the problem and get Windows to
    >run properly again. Ironically, the very fact that the bug-stricken Explorer has
    >opened these avi files makes it impossible to delete them: They are "in use by another
    >program" and therefore cannot be deleted. To sucessfully delete these avi files,
    >you have to delete them BEFORE WinXP can start its Explorer process. You can do this
    >by booting WinXP in command line mode (just hold down the F8 key during booting and
    >select from the menu). Then you can delete the avi files by entering the "del xxx"
    >command (where "xxx" stands for the path and filename of the avi file, e.g. "C:\VIDEO\TOPGUN.AVI").
    >After you reboot normally, WinXP will work properly again.
    >
    >HOW TO IDENTIFY WHICH AVI FILES TO DELETE
    >To identify which avi files are causing the problems, just boot Windows normally,
    >close any open programs and then attempt to rename each of your avi files in the
    >explorer. If WinXP won't let you rename an avi file then that is one of the trouble-causers,
    >and needs to be deleted (using the procedure described above)
     
  11. cartersa77

    cartersa77 TS Rookie

    Hi there,

    This problem seems to be quite common. What have Microsoft not fixed it?

    If not confident with command line working, I've found you can delete these troublesome files by starting Windows XP in Safe Mode.

    Cheers
    Steve
     
  12. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    It is not really a bug.. In order to show thumbnails/preview of a media file you have to read that file and if it is a big file then the process will take time. I suppose MS could optimise the way the preview is extracted from the file, but quite apparently they have better things to do than to tweak the performance of Windows :p
     
  13. ommy

    ommy TS Rookie

    0 to 100% increases with time

    I suffer from the same "problem", that is that the explorer process takes up all the cpu. I've also noticed that when my computer had just started, the process takes up 0 to 1 %, then as the minutes pass this extends to 0 - 20% and all the way up to 100% after half an hour, this would require me to reboot every 30 minutes to have my system working right.

    My system is not pretty stable apart from this problem that shows up every 3 to 4 months after a format... can i fix it without formatting again?

    ps: i've deleted the avi file handler value, so i guess that didnt help

    thanks for the help
     
  14. dagone

    dagone TS Rookie

    hey Nodsu!! just tried your reg fix and whopeee!! it worked!! But like Refwhett didn't have the \InProcServer32, just the numbers.. i guess explorer can't handle so many avi properties, better send it for a course in memory management.. lol.

    funktastic!! thanx for the fix.. this problem's been irritating me for some time now. Only way to stop it then was stop the process from task manager.

    thanx again.. tc&p
     
  15. Trippin13

    Trippin13 TS Rookie

    I have the same problem cpu 100% ... explorer ..that's all great but I don't have this location in my registry

    1. Open up regedit
    2. Goto HKEY_CLASSES_ROOT\SystemFileAssociations\.avi\shel lex\PropertyHandler
    3. Delete the "Default" value which should be "{87D62D94-71B3-4b9a-9489- 5FE6850DC73E}\InProcServer32"

    HKEY_CLASSES_ROOT\SystemFileAssociations\ is not there????

    What should I do ... (have too many avi files to rename doh) ...

    thanks
     
  16. Abraxas

    Abraxas TS Rookie Posts: 157

    I believe it suffices to change the window mode to "classic" instead of the nifty bar on the left. I have a German version and can't tell you exactly how to get there. It's the very first thing in the folder options, a radio button.
    Of course, that's a brutal solution - if any - and doesn't just mess with the *.avi files...
     
  17. rdoleman

    rdoleman TS Rookie

    It is there

    hi mate, it is there, you need to go to the bottom of the system.xxxxxxxxx and underneath you will find the SystemFileAssociations tab. Remember there is no "." after it.

    Thanks Nobsu
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...