TechSpot

file sharing with crossover cable

By apefly
Feb 17, 2007
  1. Hi,
    I'm trying to get some files off an old PC (XP Home SP2) to a newer one (XP Pro SP2). The problem I’m having is that I cannot access either PC from the other. I can ping the IP addresses but that is it.

    I've disabled firewalls/antivirus and run the XP network wizard and setup the IP address as below.
    XP Home
    IP -192.168.1.1
    Subnet - 255.255.255.0
    Gateway -192.168.1.1
    XP Pro
    IP -192.168.1.2
    Subnet - 255.255.255.0
    Gateway -192.168.1.1

    I've used this cable before and have done everything that I can think of, though I’m quite willing to admit I may have missed something really obvious!
    Can anyone tell me what I’m doing wrong?

    Thanks
    ApeFly
     
  2. kitty500cat

    kitty500cat TS Evangelist Posts: 2,154   +6

    Hello and welcome to TechSpot.

    If each drive that you want to share is the C drive, go into the C drive on each, go into properties, click on the share tab, and choose to share it on the network, which a share name of C. Now go into My Network Places, on the menu at the left click Entire Network, click on Microsoft Windows Network, click on the network name, click on the computer name that you want to share with, right click on C:\, and choose Map Network Drive.

    I think it should work, but my computer is set up on a different kind of network, so I'm not sure if what will work on mine will work on yours.

    Anyway, let us know whether or not it works.

    Regards :)
     
  3. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    "cannot access" means what?

    In a Windows Explorer window, type in "\\other.pc.ip.address\c$". You should get a password prompt. If you don't, then you either don't have file sharing enabled or a software firewall is blocking the connection.
     
  4. apefly

    apefly TS Rookie Topic Starter

    Thanks for the reply, I've tried the above.

    I don’t get a password prompt, just the error:

    "\\192.168.1.1\c$
    The network location cannot be reached. For information about network troubleshooting , see Windows Help."

    on the XP home machine and:

    "\\192.168.1.2\c$
    The Network path was not found"

    on the XP pro.

    I have definitely disable firewalls on both machines and file sharing is switched on in network setting for both.

    Could it be something else, or do I need to do something else to get file sharing to work?

    Thanks

    ApeFly
     
  5. kitty500cat

    kitty500cat TS Evangelist Posts: 2,154   +6

    But what happens if you right click on your C drive on your one machine and click sharing and security? does it say that the drive is shared?
     
  6. apefly

    apefly TS Rookie Topic Starter

    I had other shares, but I've shared the c drives of both machine jst to make sure. Still just the same!

    One other thing I have just noticed, in 'My Network Places' on the XP Pro machine it lists all ok the shares for that machine (including the newly shared C drive), but on the XP home machine 'My Network Places' is empty. I'm guessing this points to the XP Home machine being the problem?

    I've rerun the setup wizard on both and file sharing is definalty enabled, is there something extra you have to do on XP home to enable file sharing? (i've only ever really used Pro).

    Thanks
     
  7. jobeard

    jobeard TS Ambassador Posts: 9,322   +622

    both machines MUST be in the same WORKGROUP name.

    cp->system->Computer Name tab;

    ps: it's a real bad idea to share C:\ you can get smashed badly on \windows
    and never see the light of day again.

    only share FOLDERS and usually restrict it to those in
    \Docs & Settings\YourLogin\
     
  8. kitty500cat

    kitty500cat TS Evangelist Posts: 2,154   +6

    how would you get smashed?
     
  9. jobeard

    jobeard TS Ambassador Posts: 9,322   +622

    Once you share C:\ I can remove software from \windows or substitue
    drivers and install rootkits.

    Sharing C:\ is intended for commercial IS companies to manage the client
    PC population with
    remote installs and updates.

    Anyone not using a router should NEVER share C:\

    Unless you strictly control file sharing permissions, hotspots and even
    your own private LAN can put you at risk.

    CAVEAT EMPTOR!
     
  10. kitty500cat

    kitty500cat TS Evangelist Posts: 2,154   +6

    i see.

    I guess this would have to do with that thread you had made earlier about internal network attacks.

    so go ahead you guys, you know more about networking than I do.

    Regards :)
     
  11. mikescorpio81

    mikescorpio81 TS Rookie Posts: 293

    Get rid of the gateway. Your PC is 192.168.1.1 and so is its default gateway. when you statically assign them IP credentials, leave the gateway blank and try again.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...