Fix for mouse / audio stutter, computer slowdown FIXED!

By rgusto
Sep 3, 2007
Topic Status:
Not open for further replies.
  1. Hi, I'm posting to share a fix for a sudden problem I encountered. The problem was my computer started running very slow, the mouse would stutter (especially if more than 1 program was opened), my audio (from all players and my recording software) would stutter and skip A LOT! Was very frustrating/painful. I really dont know anything about computers, so i took it to Geek Squad. They did a diagnostic test ($59) and said it failed their hard drive test. They said i needed a new hard drive and everything would need to be reinstalled! I just couldnt believe my 1 yr old HP zv6000 that i just cleaned/deleted a bunch of stuff went from working perferctly to having a bad hard drive.

    Soooo, i read A LOT of internet postings on the same problem and tried a few things (chkdsk, disk frag, etc)...THEN...i decided to search under "itunes stutter". And there it was...a fix. And how simple it was. I 've copied the text 'cause i dont think i could word it correctly... Here you go. Good luck! Basically, uninstall the primary ide if its PIO mode (which my computer automatically switched to after a few poor shut downs on my part). THE FIX IS to get it back to DMA mode. To see what mode youre in now, go through the Device Manager, open the primary ide, right click to properties, go to advanced settings, and look at Current Transfer Mode. If it reads PIO Mode, click on the Driver tab, click on Uninstall, OK, reboot, etc and thats it!...read the solution below...and thats it! When you reboot after you uninstall it, it's automatically set back into DMA mode...and that's it! WHOOOOHOOOO!!! Amen. Here:

    To enable DMA mode using the Device Manager

    1. Open Device Manager.
    2. Double-click IDE ATA/ATAPI Controllers to display the list of controllers and channels.
    3. Right-click the icon for the channel to which the device is connected, select Properties, and then click the Advanced Settings tab.
    4. In the Current Transfer Mode drop-down box, select DMA if Available if the current setting is "PIO Only."

    If the drop-down box already shows "DMA if Available" but the current transfer mode is PIO, then the user must toggle the settings. That is:

    • Change the selection from "DMA if available" to PIO only, and click OK.

    • Then repeat the steps above to change the selection to DMA if Available.

    Changed the drive to DMA from PIO and itunes and all windows sounds work fine again.

    On your Primary IDE Channel-Device 0, which you state is set to "PIO" mode, have you already tried setting its transfer mode to "DMA if available"? That might be the source of your problem.

    Don't worry about uninstalling the drivers/devices, Windows will pick them back up on reboot.
  2. Condor

    Condor TechSpot Maniac Posts: 461

    glad u fixed the problem =]
    should get your refund from those the geek squad > : )
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.