TechSpot

Folder Sharing Issue: This one's a toughie guys!

By Sesamebabe
Oct 30, 2007
  1. Hi everyone! This is my first post here on this community and I am hoping to become an active member in the months ahead!

    I am experiencing a very unique issue that I am hoping someone might have a fresh perspective on, it has to do with folder sharing options under the security tab on a local computer...

    We currently swithced over to a domain based network in order to accomodate some heavy duty software that was loaded onto our server. This software can only be loaded onto local workstations by pulling the install files from a Deploy folder on the server. Once the software is fully installed, and the local workstation user needs to open the software, it is pulling some data from the server but also needs to access some files from the local computer (specifically from the "Temp" folder and the "System32" folder under the WINDOWS folder in Docs and Settings.

    So on the majority of our computers I just right click on the Temp and Sys32 folder, go to the Security tab, and add the domain user on to the Groups and Users area without any problems b/c the local computer and security settings can see the domain server. Well this is where it gets weird....

    I am on this one particular workstation and when I try to go through the same process, I am not able to add any domain users to the security group/users b/c for some reason the workstation is not seeing the domain server - only the local computer - eventhough I am officially logged in and connected to the domain as the domain administrator!!!!

    So if I try to add a user from the domain, it tells me it can't find it b/c the only location it can access is the local workstation.

    I have tried everything from disconnecting and re-connecting to the domain, restarting the computer a number of times, deleting the computer name off of the actual server, etc. - nothing is working!

    Any other suggestions besides re-building the computer????
     
  2. tipstir

    tipstir TS Ambassador Posts: 2,393   +107

    Welcome to TechSpot!

    Are you the admin of that workstation that has the software you need to install on other system on the network? You should use Active Directory and assign that workstation and anyone who has rights the to access the data you need. You could use SMS to push the software down. I rather use AD Managed Software to do it better. Most likely you'll need some scripts to perform these task. If you don't want to do it that way you could again go into active directory assign access rights for tech who has admin rights who could access the system to pull down the software manually for each PC. Again that would take time to do. Most companies use SMS or some deployment tool to install updates an etc..

    Can Active Directory under Users and Computer can you see the PC? Yes or No?
    Can you ping this PC
    As it setup correctly on the domain.
    Go to that PC and take it off the domain and put in on a workgroup.
    Then when you log back in to the PC add it to the domain.
    If it doesn't get added then go into Active Directory and see why?

    How many Certifcate Licenses did you get for your server connections? Something else you should get into?
     
  3. Sesamebabe

    Sesamebabe TS Rookie Topic Starter

    Thanks for the prompt reply!
    The issue lies on the folder sharing options on the workstation itself - not on the server. I have no problems with getting the info from the shared folders on the SERVER, but there are 2 folders that are on the workstation itself that need to be shared with other users on the computer besides the local administrator - I guess a better way to state the problem is:

    How do I share a local computer folder with other users on that same computer that are DOMAIN users and not local users?

    When I try to add users under the security tab it shows who has access to that folder, so for example it currently shows:

    COMPUTERNAME/Administrator
    COMPUTERNAME/Users
    SYSTEM
    COMPUTERNAME/Power Users

    What I need it to say is:

    SERVERDOMAINNAME/Administrator
    SERVERDOMAINNAME/Users
    SYSTEM
    SERVERDOMAINNAME/Power Users

    But no matter what I do I am not able to change this. And the reason this is such a problem is b/c when I input a domain user name into the "Check Names" box under the "Add..." button, it tells me it can't find it b/c the only location it is scanning is the local computer of COMPUTERNAME/Users.

    I assume that if I tried inputting another local user name from that computer it would be able to find it, but that won;t help me b/c for security purposes I only want domain users to be able to access the server and this software and the 2 folders on the local computer workstation. Does this clarify anything?
     
  4. tipstir

    tipstir TS Ambassador Posts: 2,393   +107

    How to...

    click on start
    then on run
    type: C:\windows\system32\compmgmt.msc

    Local Users and Groups

    Users - add a users name say fred stone and create a password
    Groups - add the user fred stone to the administrator group

    Also Shared Folder open Shares and add access to the folder you want
    and give it a setting so you can permit the number of users you want to access this folder.

    I rather do this in Active Directory, create account for fred stone and password. Give that account access to admin group.

    Then go back to the PC in question and create a user called Fred Stone
    Then add fred stone to the administrator group.

    Reboot the PC

    So this Fred Stone can now access any file on that workstation.

    Now way around all of this above is to do this... Each workstation should have a default admin.. But if you use the Fred Stone to be admin of all domain workstation he or she will be able to log in to any PC on the network there as the local admin.

    Try this...

    from a remote PC


    click on run
    type: \\computername\C$

    Now you will get a popup for Connect to computername
    User name might be grey out or not.

    If it greyed out then you have to get into the Security Policies of that PC and enable the Guest Mode or call it a different name like Fred Stone

    click on start
    then on run
    type: C:\windows\system32\secpol.msc

    Under Security Settings
    Under Local Polices
    Under Security Options
    Here is where you need to make your changes..


    click on start
    then on run
    type: C:\windows\system32\gpedit.msc

    Under User Configuration
    Under Administration Templates
    Under Shared Folders

    Make sure it's Enable and make any additions you need here.

    Again a lot of this can be administered on Active Directory.. But if you problems then do the above for that workstation.

    Good Luck!
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...