TechSpot

Games running way too fast

By leonares
Mar 18, 2009
Topic Status:
Not open for further replies.
  1. Okay, these are my graphics card and processor respectively.

    ATI Radeon 3850
    AMD Athlon 64 X2 Dual Core Processor 5200+

    I have the most recent updates for the graphics card and Windows XP. While playing Star Wars KOTOR 1 & 2, a few games around the same age, or even newer games like Assassins Creed the game plays as if its in fast forward, though the original Doom runs perfectly fine. The character models look like they are having seizures, the sound is either low quality or cannot be heard over the static. I have tried cpukiller which helps somewhat during game play but and cinematics still play at their enhanced speed. I have maxed out everything I can on my graphics card which has shown no noticeable improvement. I believe that it is a framerate issue but I can not find a way to lower the framerate using ATI Control Center or Windows Preferences because they only offer 60.
     
  2. redk

    redk TS Rookie Posts: 135

    Try setting the game to only use one core.
    To do this, ctrl alt del > processed > (Whatever the game exe is) right click, affinity, and uncheck one of the cores.
     
  3. leonares

    leonares TS Rookie Topic Starter

    Thanks but it didn't work, what does that do if you do not mind answering?
     
  4. SNGX1275

    SNGX1275 TS Forces Special Posts: 12,551   +301

Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.