GeForce 4 Ti 4200 Driver

By Defacto
Oct 29, 2003
  1. Hey guys, I just bought FF XI and when I try to play it my video is screwed up and I can't see anything. I have tried downloading new drivers but while I'm installing them it stops mid install. I have to ctrl-alt-delete to quit the program even though it isn't unresponsive. Any idea what would cause this or where I can find some drivers that would work?
  2. StormBringer

    StormBringer TS Rookie Posts: 2,244

    did you remove the prior set of drivers first? Did you disable your AV software and any other monitoring apps before trying to install the new drivers?
  3. TS | Crazyace

    TS | Crazyace TS Rookie Posts: 275

    I personally suggest when replacing a video card from a different manufacture than previous, best common practice is to reformat the hard drive. Uninstalling the drivers simply does not rid of all the registry additions. You can try using reg cleaners, etc,
  4. .asinine*

    .asinine* TS Rookie


    Hey guys.

    When i am playing games (counter-Strike), i can usually play with out any problems for like 5 mins, then the screen starts flickering until it turns black and it either says no input signal or it just freezes. i was wondering if anyone can help me with this problem.. would it be the videocard or the monitor? any comments back will be appreciated. thanks ( i got a flat panel monitor)
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...