Graphic card upgraded, but help sought

By scotbruce
Dec 25, 2002
  1. I installed a GeForce2 Ti on my son’s computer (details below) this morning, after previously researching on this and other fora. Unfortunately, he cannot play the likes of Driver, Tony Hawk 2, Phantom Menace or Alien vs Predator, which was the whole idea of the budget graphics card upgrade. (Commandos 2 and Deus Ex both work fine, however). The Driver configuration cannot find a 3D device. DirectX says there’s no Direct3D enabled. I’ve removed the graphic card and re-installed it. Should I look for another driver for it – or any other potential software upgrade? Help!
    500 megahertz Intel Pentium III 9.28 Gigabytes Usable Hard Drive Capacity 2.30 Gigabytes Hard Drive Free Space Board: LEGEND.QDI(R) BrillianX-1S/2K V1.XX Bus Clock: 100 megahertz BIOS: Award Software International, Inc. 4.51 PG 12/08/1999 160 Megabytes Installed Memory Windows 98 SE Standard Floppy Disk Controller Intel 82371AB/EB PCI Bus Master IDE Controller Primary IDE controller (dual fifo) Secondary IDE controller (dual fifo) Intel 82371AB/EB PCI to USB Universal Host Controller Inno3D GeForce2 Ti [Display adapter] ASTVision 4I [Monitor] DirectX 8.2
  2. ---agissi---

    ---agissi--- TechSpot Paladin Posts: 1,977   +15

    Well the problem is your computer cannot reconize the card. Have you ever used the AGP port before? It could be shot. and/or check that any old video card drives are uninstalled. One thing that may help, is check what port your video card is using, and check that D3D is also enabled to read it. Hope this helps...=/
  3. scotbruce

    scotbruce TS Rookie Topic Starter

    sorry, how do I enable 3D?
  4. iss

    iss TechSpot Chancellor Posts: 1,994

    Did the machine have a video card in it before installing the Gf2? or did it use integrated graphics? if it used integrated graphics before then the integrated graphicswill have to be disabled before the board will recognize and use the AGP card. on older boards this was usually done via a jumper on the board or sometimes in the bios. you should check the bios setting to make sure that the setting for graphics is set on AGP not PCI.
  5. scotbruce

    scotbruce TS Rookie Topic Starter

    It had an ati rage pro 8mb agp card in it. I'll check the bios, though.....
  6. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +7

    it may be possible to just disable it in the BIOS, however as ISS notes there may be a jumper as well. Check your motherboard manual or download it if you don't have it.
  7. young&wild

    young&wild TechSpot Chancellor Posts: 993

    Search for "DXDIAG.EXE"
    Double click the file.

    Click on the "Display" tab

    Under the "DirectX Features" Check if the following are enabled: DirectDraw Acceleration, Direct 3D Acceleration, & AGP Texture Acceleration.
  8. ---agissi---

    ---agissi--- TechSpot Paladin Posts: 1,977   +15

    Sorry scotbruce...never got back to you on that one. Thanks "bart".
  9. young&wild

    young&wild TechSpot Chancellor Posts: 993

    No worries, mate!
  10. scotbruce

    scotbruce TS Rookie Topic Starter

    Sorry, I knew about dxdiag, but could not enable D3D there as it was shown as not available.

    Solution found
    display properties - settings - adapter - hardware acceleration setting changed to full - Direct3D now enabled - all games working - son happy - problem resolved.

    Thanks to all.:grinthumb
  11. scotbruce

    scotbruce TS Rookie Topic Starter

    I did put on DirectX 9 as well...
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...