TechSpot

  1. TechSpot Forums are dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot Forums are dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Had to reinstall windows on my boot camp, and it now won't let me play games.

By Nemean ยท 5 replies
Jul 21, 2008
  1. I'm not sure if there's anything else.
    My dad took an entire day to get everything set up, and it was working great. Later, after a botched attempt at installing Sims 2, I got a black screen with white text saying that "Windows did not shut down properly" and gave me some options.

    I tried safe mode, I tried starting up normally, and none worked. I got black for a bit, a blue screen popped up to quickly for me to read it, and it went back to the black screen with white text. I looked around on the internet, and someone suggested I reinstall Vista. I really should have known it would be too easy.

    I tried to start up Oblivion, and I got a message saying "Failed to initialize renderer. NiXAdapterDesc::GetDeviceCaps() failed."

    Dungeon Siege 2 gets me "A fatal error has occured and the app must shut down.

    Unable to enumerate any DirectDraw devices installed on this system.

    [Note: This error can occur if another application has exclusive control of the display. For example, Netmeeting's desktopsharing feature may be enabled or you are trying to run this app thorugh a remote desktop in Windows XP or Terminal Server. It can also occur if your hardware does not support 3D acceleration or if your video driver does not properly support Direct X 8.)"

    Age of Mythology started working after I managed to get internet connection, but it plays the pre game videos then I get a black screen with the pointer on it.

    These games had NO problem before.

    If anyone could tell me what is going on and how I can fix it, it would be greatly appreciated.
     
  2. CCT

    CCT TS Evangelist Posts: 2,653   +6

    Time to reformat and reinstall - find some Vista install guidelines for your comp or motherboard (Google is a friend) that include motherboard chipset drivers RIGHT AFTER Vista install, etc.

    Oblivion would be the first game to try - stable and well made.

    If it runs, then add the patch(es).

    Edit: btw: I think this area is for Linux ! LOL
     
  3. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

    Have you run all the updates from Windows (Mac-Bootcamp) Update?
     
  4. Nemean

    Nemean TS Rookie Topic Starter

    Thank you so much CCT! It's working now!
     
  5. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

    So just to re-confirm
    It was drivers that needed to be updated on your Motherboard or Video Card? that solved it.
     
  6. LNCPapa

    LNCPapa TS Special Forces Posts: 4,222   +426

    After a fresh install of Windows in bootcamp the first thing you should do is put the Leopard disk in the drive while booted into Windows and install the bootcamp drivers - these contain Apple's Windows drivers for their hardware. I would also suggest that after you've done that you make sure you have bootcamp 2.1 installed - these are updated drivers from Apple, but for certain devices it requires you to have already installed the initial driver set from the Leopard disk.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...