Have a Gateway 7500 series laptop with Power Issues

By charlenein
Jan 29, 2008
Topic Status:
Not open for further replies.
  1. Lately I have been having power issues. my laptop is always plugged in (power surge protecter used) i shut it off when not in use. but now even though it is using 100% AC adapter for power; the Li-ion battery is draining, and the laptop shuts off after about 15 min. i have tried to use the laptop with out the Li-ion battery and it shuts off after about 15 min. i have switched outlets and there is no change.

    i do use a chill pad at all times. and i have checked all connections and everything is plugged in.

    Any suggestions?

    charlenein
  2. raybay

    raybay TechSpot Evangelist Posts: 10,716   +6

    Inspect your battery, and power adapter very carefully for bent pins and contact strips. Assure best contact by bending them outward ever so slightly.
    Then consider buying an official Gateway power adapter on eBay.
    Power adapters fail frequently enough to distrust them. Batteries have never been as reliable as one would like.
    Too much heat or too drastic a cold will ruin the power adapter or the battery. Do not leave any of them in a car during summer or winter temperatures.
  3. charlenein

    charlenein Newcomer, in training Topic Starter

    thank you i got a new adapter and everything is they way it used to be.
  4. raybay

    raybay TechSpot Evangelist Posts: 10,716   +6

    Thanks for the update. It is always good to know what really happened.
  5. charlenein

    charlenein Newcomer, in training Topic Starter

    No problem, it must help to know so you know for next time right?

    thank you again
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.