TechSpot

HD 4850 driver 10.3 troubles?

By Manikle
Apr 5, 2010
  1. Periodically, I get BSODs which seem to be a result of my HD 4850 "ATI RAdeon Kernel Mod Driver".
    I was going to update to the latest driver, but have read of people having problems with the latest driver v10.3.
    Anyone here update to this newest driver--did you have any problems and which OS are you using?
    I'm using Vista 64 bit.
    Thanks.
     
  2. EduardsN

    EduardsN TS Rookie Posts: 56

    For some reason with previous drivers I had a weird problem with my display, it was blurry for some reason on 60hz refresh rate specially in the middle of the screen but was perfectly sharp when using 75hz. With the new 10.3 drivers dont have this problem, and no new problems either.
    Something with AA I guess.. but anyways I'm running Vista 32bit
     
  3. red1776

    red1776 Omnipotent Ruler of the Universe Posts: 5,913   +92

    I'm running 4 X 4850's so its a little more touchy, but I had problems with 10.2. 10.3 is running smooth as glass though. I am using Vista 64 as well. General consensus with 10.3 has been very good, I would go ahead and upgrade to 10.3.
     
  4. EpicPie

    EpicPie TS Rookie Posts: 55

    My HD 4870 is running fine with latest drivers, haven't had issues with anything and even with it being overclocked.
     
  5. Manikle

    Manikle TS Rookie Topic Starter Posts: 67

    Thanks to everyone for responding.
    Hopefully, my update will work as well.
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.