TechSpot

How do I set my notebook to automatically connect at startup?

By Slick21
Jun 18, 2012
Post New Reply
  1. I'm using Windows 7, a ASUS X54C Notebook and a DLink WBR-1310 router.

    For some reason when I reboot my notebook, the wireless compatibility doen't want to automatically connect to my wireless access point. I have to manually click the wireless icon on the task bar to let the troubleshooter connect my notebook to the internet.

    I already have the options under properties and services.msc via WLAN AutoConfig enabled to connect automatically at start up, but that doesn't seem to help.

    Anyone have any ideas?
  2. learninmypc

    learninmypc TS Evangelist Posts: 5,233   +232

    I don't know if this will help,but I don't think it'll hurt. http://computer.howstuffworks.com/how-to-set-up-wifi-laptop.htm
    I fixed a friends W7 wireless connection last week but don't remember the steps,good luck.
  3. Slick21

    Slick21 TS Rookie Topic Starter Posts: 22

    I followed the link you gave me, but that didn't really help. The only thing I changed was the SSID and a different WPA 2 encryption setting with a different password.
  4. learninmypc

    learninmypc TS Evangelist Posts: 5,233   +232

    Ok,I'm sorry it didn't work for you. I might be getting my friends W7 laptop this weekend & if so,I'll do my best to see if I can tell you what I did.Hopefully you'll get it taken care of before then.
  5. Slick21

    Slick21 TS Rookie Topic Starter Posts: 22

    Ok then, thanks.
  6. jobeard

    jobeard TS Ambassador Posts: 13,408   +314

    1) delete the connection
    2) reboot
    3) recreate the connection and be sure to allow Automatically Connect

    If you visit various hotspots, then be sure to disallow that and do it as you are now (ie manually)
  7. GeforcerFX

    GeforcerFX TS Booster Posts: 330   +48

    I have had the problem before, jobeard is right with deleting the network and reconnecting, when you reconnect just select the automatically connect too this network check box(was selected by default on mine) and that fixed mine, hope it works for you.
  8. Slick21

    Slick21 TS Rookie Topic Starter Posts: 22

    Deleting the connection and reconnecting did not work. And as I said before in the topic, the automatically connect check box
    was already checked. I think the problem might be the wireless compatibility feature not automatically being turned on

    Because every time I reboot and run the troubleshooter, it says that it's not turned on.
  9. GeforcerFX

    GeforcerFX TS Booster Posts: 330   +48

    well simple question, if there is a wifi switch (one built in too the laptop) make sure its on. try deleting the driver for the wifi adapter and reinstalling the drivers or even download the newest ones tat asus has published for your system. That's all I can think of that's left other then maybe a full reinstall.
    Slick21 likes this.
  10. learninmypc

    learninmypc TS Evangelist Posts: 5,233   +232

  11. Slick21

    Slick21 TS Rookie Topic Starter Posts: 22

    Yeah, that's it.
     
  12. Dawn1113

    Dawn1113 TS Booster Posts: 375   +64

    I've had this problem before, but I've always solved it by recreating the network as suggested by jobeard.

    Have you always had this problem or is this a recent development? Does your laptop detect any other networks in your area?
  13. learninmypc

    learninmypc TS Evangelist Posts: 5,233   +232

    Ok,on the laptop I previously mentioned, there was a tiny BB (as in BB gun) sized light in the upper right area. Does yours have that? If so, what color is it?
    IF I remember correctly, locate the fn key & I think either the Shift key & fn or Ctrl & fn & press them & that tiny light should change colors.
    Otherwise I'll try to get my hands on that W7 laptop this weekend to see if I can help further.
  14. Slick21

    Slick21 TS Rookie Topic Starter Posts: 22

    Maybe I'm recreating the network the wrong way in control panel. Can you give me
    the steps to do it properly?

    It's happened since I connected my laptop to the router for the first time. I've had the laptop for about a week, I've just been using the modem/router on the laptop through a wired connection while I was getting my Desktop PC repaired.

    There's no light or anything of that sort in the upper right hand as you described. The
    only lights I see are the ones at the bottom of the keyboard. 1st one is yellow and 3rd one
    is flashing, the others are empty. The key techniques you gave me didn't do anything.
  15. learninmypc

    learninmypc TS Evangelist Posts: 5,233   +232

    As asked in post # 9, is there any type of a switch/lever on the laptop you can slide/move that might have a wi-fi icon ?
    Slick21 likes this.
  16. Slick21

    Slick21 TS Rookie Topic Starter Posts: 22

    That worked!! Based on my light and the icon that you showed me, it turns out that I needed to turn on the WLAN through the function key. This was done by simply holding down FN and pressing F2.

    I can now connect automatically through reboot. Thanks for the help everyone.:)
  17. learninmypc

    learninmypc TS Evangelist Posts: 5,233   +232

    Absolutely awesome. Happy surfing:)(y)


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.