TechSpot

How to access my BIOS after virus disabled it

By dar3_hunt3r
Aug 15, 2008
  1. How can i enter into my bios after my notebook was infected with a dozen virus. i tried to reformat it but i can't even enter into my bios to switch my booting sequence. i tried installing a new version of windows but it keeps on corrupting the new system. my only option was to reformat my hard drive, but i can't use my bootable cd. is there anyone who can help me with this? a help is greatly appreciated.

    My notebook is Dell inspiron 5100.

    And oh, is there anyway i can reset my bios?
     
  2. kimsland

    kimsland Ex-TechSpotter Posts: 18,353

    There's no jumper, so without the reset code from Dell, unsoldering the CMOS or trying some pretty sketchy software are your only options.
    Sketchy software: KillCmos; ClrCmos etc etc

    But normally it is next to impossible that you have a virus in your Bios, unless someone has tried a faulty Bios update on it

    You are not talking about a passworded protected bios are you?
     
  3. dar3_hunt3r

    dar3_hunt3r TS Rookie Topic Starter

    Yes, i know that it maybe impossible to infect the bios. but i think it may had altered something, it just keeps on ignoring whenever i press the F2. so, any idea how to get in?
     
  4. dar3_hunt3r

    dar3_hunt3r TS Rookie Topic Starter

    or is there anyway that i can boot through cd since i can't change my booting sequence.
     
  5. raybay

    raybay TS Evangelist Posts: 10,716   +6

    Look for other causes. BIOS does not get infected. Hardware can get damaged, and that affects the BIOS. CMOS battery can fail, halting the BIOS. Errors can be made to the BIOS, making it inoperable.
    You are not correct about your "only option." You haven't begun to look for the causes of the problem.
    Have you looked at the Device Manager to assure there are no yellow or red flags?
    Have you looked at Disk Management in Computer Management? Have you looked at the other possibilities in Administrative Tools, Computer Management, Hardware in System of Control Panel?
    One likely possibility is damage to drivers, or incorrect edits to BIOS.
    What do you get when you boot to F10 and F12, and <DEL>.
    Hardware errors to the chipset, hard drives, etc. are a good place to start.
    First, I would run a drive fitness test, then memtest86 for four hours or 7 passes, then a full download of all Dell 5100 drivers... if the checks of computer management show nothing.
    Have you attempted a cold Boot to Safe Mode?
    Have you attempted changing the boot sequence, then rebooting, to the CD, and letting a "repair install", not a Repair Console repair, run?
     
  6. dar3_hunt3r

    dar3_hunt3r TS Rookie Topic Starter

    all of my hardware except the modem are working properly.. the problem just started when my notebook was infected with a virus that came from a flash drive. if it's hardware error to my chipset then its good as gone then. i tried fixing it in safe mode but to no avail either. yes, i've tried with administrative tools but i'm still not good how to handle it efficiently. yes, that's why i'm trying to figure out how to log into my bios so i can change the booting sequence.. i've tried reinstalling my (windows xp sp2) and upgrading it into a newer version yet with no avail also.
     
  7. kimsland

    kimsland Ex-TechSpotter Posts: 18,353

  8. raybay

    raybay TS Evangelist Posts: 10,716   +6

    Good idea, Kimsland
     
  9. dar3_hunt3r

    dar3_hunt3r TS Rookie Topic Starter

    hey thanks. yeah, i figured it out already. my F2's not working when i'm starting up. even when i'm installing a new OS. i think the virus did this. when already in windows, the f2 works fine.
     
  10. raybay

    raybay TS Evangelist Posts: 10,716   +6

    You could have a virus, but it is not in the BIOS. Look elsewhere to figger out where it is causing trouble.
    If your Antivir antivirus, SuperAntispyware, NOD32, Kaspersky, MalwareBytes, Spyware Doctor 6.0, or Spy Sweeper do not find it in your scans, that is not the problem. Look for hardware issues...
     
  11. dar3_hunt3r

    dar3_hunt3r TS Rookie Topic Starter

    Geez.. i can't connect to the internet since it has been disabled.. here's the culprit i think: keyboard.exe, font.exe, global.exe, default.exe, another version of svchost.exe, wscntfy.exe. anyone knows about this? i can't seem to shake it off. it just keeps comming back. kaspersky can't detect it too.
     
     
  12. kimsland

    kimsland Ex-TechSpotter Posts: 18,353

  13. kajal

    kajal TS Rookie

    I have vostro 1500, I have the same problem except i can access my bios and also have the recovery drive provided by the Dell but i can't start my vista home...what should i do...please help...also i cannot install new vista cause weird error saying you don't have any access to the hard drive and now drive is not available.
     
  14. kimsland

    kimsland Ex-TechSpotter Posts: 18,353

    This thread was about a Dell inspiron 5100 with a possible faulty Keyboard (or not recognized through bios) and Virus activity.

    No you don't

    You have a Dell vostro 1500 with the Hard Drive not being detected !
    Totally unrelated.

    You need to start your own thread in Mobile Computing
    By the way, you could also try removing the HardDrive, and re-inserting it.
    Other than that, you need to start your own thread
    Do not reply here.
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.