TechSpot

How to solve USB related crashes ?

By cacophony
Feb 11, 2008
  1. Hi,

    I'm running Windows XP Professional SP2, and i've been having an issue with the following symptoms:

    1. Continuous pop-up notifications on task bar warning me that "USB device not recognized" even though no USB device is connected

    2. Sudden reboots occasionally occur and the file dump points to USB as the cause
    (You can see the minidump here ( forums.hardwareguys.com/ikonboard.cgi?act=ST;f=17;t=6371#postid45832 ), but you'll see it has "IMAGE_NAME: USBPORT.SYS")

    3. Delayed startup with black screen

    4. I've got a bunch of BSODs while trying to plug in and access various USB devices

    My first step was to look at the device manager, but it claimed that all the USB drivers were running fine with no issues.
    Here's what was listed:
    inter® 28201g (ich7 family) usb universal host controller - 27c8
    inter® 28201g (ich7 family) usb universal host controller - 27c9
    inter® 28201g (ich7 family) usb universal host controller - 27ca
    inter® 28201g (ich7 family) usb universal host controller - 27cb
    inter® 28201g (ich7 family) usb universal host controller - 27cc
    intel usb root hub
    intel usb root hub
    intel usb root hub
    intel usb root hub
    intel usb root hub

    There were no exclamation marks, and all said "device is working properly" under status.

    I tried upgrading the drivers but i couldn't find newer versions on the intel website. I did install all the latest drivers for other components that were there though, and updated the bios as well.

    If i manually disable all the above USB controllers, then the 4 problems above seem to go away.

    I tried doing an uninstall on the 5 USB controllers, followed by a scan for hardware changes, and then let windows re-install these controllers. Windows then installed its own drivers for the USB devices, and those drivers appear to be different than what i had before. (now they are called "standard universal pci to usb host controller" instead of "inter® 28201g (ich7 family) usb universal host controller")

    This seemed to fix things at first. I was successfully syncing my ipod fine and wasn't getting any of the 4 issues. But then today while booting up my computer i decided to plug in my camera. The boot process went black for awhile and then I got a BSOD. After restarting my computer i was once again getting "USB device not recognized" messages irregardless of whether anything was plugged in.

    I've once again disabled and uninstalled the controllers, but now i'm not sure how to proceed. I really need to be able to access USB devices, but all the stability issues are driving me crazy.

    I don't know if it matters, but here's my hardware:
    Intel boxd945psnlk lga 775 intel 945p atx intel motherboard
    Intel pentium 4 630 prescott 3.0ghz lga 775 single-core em64t processor model bx80547pg3000f
    Crucial 1gb (2 x 512mb) 240-pin ddr2 sdram ddr2 533 (pc2 4200) dual channel kit desktop memory model ct2kit6464aa53e
    Evga 256-p2-n389-ax geforce 6800gs 256mb 256-bit gddr3 pci express x16 sli supported video card

    Any advice would be greatly appreciated,
    Dan
     
  2. raybay

    raybay TS Evangelist Posts: 10,716   +6

    This is not a commonly reported problem with the 945p.
    Have you thoroughly checked your computer motherboard for damage to the USB socket?
    What you report is more typical of a computer using a USB reader.
    It may be worthwhile to reformat and reinstall Windows.
     
  3. cacophony

    cacophony TS Rookie Topic Starter

    I don't see any visible signs of damage but it's hard to see much. BTW, the only USB ports I've used are the two that are on the front of my Antec Sonata case. I've never used the ones that stick out the back of the motherboard.

    Short of reformatting my drive and reinstalling everything, what can I try? Seeing that the issues go away with the disabling of USB, shouldn't there be a simpler fix?

    What about buying a PCI USB card? Might that help?

    What about other drivers?
     
  4. jobeard

    jobeard TS Ambassador Posts: 13,517   +336

    the ports on the front are typically usb 1.1 while those on the back are usb 2.0

    try those!
     
  5. raybay

    raybay TS Evangelist Posts: 10,716   +6

    We have not found that to be the case. We have been testing the USB ports of all computers that come into our shops. We use the LeCroy UPT2 test equipment (formerly Computer Access Technilogy Corp CAT2 - see www.LeCroy.com and www.catc.com) and have found both the front and rear ports both test at 2.0 on nearly all machines. That has been the case for over three years.

    However, we have found that on well over 50 percent of the computers tested, the speed drops dramatically on the front ports if the rear ports, or the internal port, are in use. On cheaper systems, the more devices connected to USB ports, the more dramatically the speed drops on the additional ports.
    Devices such as the Adaptec cards, and some of the better boards have no significant drop in speed when additional ports are in use.

    We have found others who believe the front ports are only at the 1.1 speed, but the problem is usually caused by the test instruments being used. Many computer repair shops buy test devices that are designed only to test the connection is working, and not the speed. Those devices only test for a speed of 1.1.
     
  6. cacophony

    cacophony TS Rookie Topic Starter

    I actually tried disconnected the front ports and only using the back ports but had the same issue =(

    Should I try getting a PCI USB card?
     
  7. raybay

    raybay TS Evangelist Posts: 10,716   +6

    Good buy, as long as you do not go cheap. Adaptec, D-Link, Logitech, SIIG, ADS, StarTech are all pretty good along with a few others are well worth the investment. Many have both USB and Firewire. If you get the ones with the high speed FireWire, you will have a tool of multiple uses.
     
  8. jobeard

    jobeard TS Ambassador Posts: 13,517   +336

    raybay: my laptop at least is very specific on this issue and has exactly one USB 2.0
    on the rear (the lower slot) and all others are specifically USB 1.1

    the device manager will help you determine the mix of 2.0/1.1 but not show you which is which :)
     
  9. raybay

    raybay TS Evangelist Posts: 10,716   +6

    Good to know. I noticed you did not specify the brand or model.
    Still, we test all models of computers before they go out after repair. We haven't seen one as you describe since the new LeCroy tester came out.
     
  10. jobeard

    jobeard TS Ambassador Posts: 13,517   +336

    Mine is a Toshiba mx35-s161

    they seem to have different models with variations of USB support -- don't recall specific, but a friend has one with ONLY Usb 1.1 :(
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.