HP 6710s power on issues

By geek300
Feb 18, 2012
Post New Reply
  1. Hello guys,

    I upgraded my hp 6710sw laptop to a 500GB HDD after the previous one-160GB-crashed. All was ok until recently it wldn't recognise the new HDD on bootup. I removed the cmos battery for 5 & then booted. The machine recognised the HDD but the unit then asked for the PowerOn pw. As I've never had this pw, I re- removed the cmos battery for 5 & then tried to reboot again but now there's no power at all, no light in the on/off button & none of the usual start up noises & the HDD isn't spinning. So far I've done the following:

    1. removed the battery, plugged into 240V & then held the power on button down for 30secs to 3 minutes.
    2. charged the battery & tried the above from the battery.
    3. tried a different charge pak which works ok with other machines.
    4. tested my charge pak with a volt meter which indicates all ok.

    One other thing, when I removed the cmos battery the 2nd time, I accidently dropped it onto the mobo for about 2 secs but I don;t think this has any bearing on the issue. HP tech help suggests turning it in to a qualified techy but I need a second opinion.

    any advice much appreciated in advance
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,233   +234

    The motherboards bios might be damaged now. A new motherboard may be the only fix...
  3. geek300

    geek300 TS Rookie Topic Starter

    righto thnx TMagic-I thought the same....I've priced replacement mobo on ebay as well as other sites & it looks like 200 AUD but i like the 6710s - it has the big square screen of yesteryear & when cranking ok has plenty of startup speed & almost instantly online even when loaded with kaspersky

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...