I cannot update my ATI Catalyst drivers! I get an error message.

By Parahex
Mar 27, 2006
  1. Like in the title. I have a picture to show you. I am trying to update my old 5.13 ATI Catalyst video drivers to the new 6.3 drivers. But I get this message when trying to install. Help?

  2. peterdiva

    peterdiva TechSpot Ambassador Posts: 1,088

  3. Frostyr0d

    Frostyr0d TS Rookie Posts: 91

Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...