TechSpot

I need help with lag on runescape

By mastr chaos
Nov 11, 2005
Topic Status:
Not open for further replies.
  1. I tried everything that jagex told me to do but it does not work. Everytime i walk somewhere and the screen says loading -please wait i lose the connection. Can someone please help me? I have tried runescape forums but they did not help me. (off topic, look its chef :chef: omg!)
  2. AtK SpAdE

    AtK SpAdE TechSpot Chancellor Posts: 1,846

    Ok we need more info..

    You should fill in your hardware specs....but runescape shouldnt need much :haha:

    What type of connection are you running. I know the game is playable on dial up (im that old school) are you having any other issues with you connection

    And have you just started the game? Or have you been playing awhile, and you have just recently gotten this message

    Sean
  3. runescape

    runescape TS Rookie Posts: 60

    use mozilla and make sure u got nothing running in the background while playing and also make sure you have atleast 512mb ram and 128 mb video
    that all you really need and a connection that is over 20kbp/s
  4. leadpill

    leadpill TS Rookie Posts: 20

    Try ending some of your proccesses that aren't being used, and maybe run a spyware+virus scan. When I play runescape (only when I'm desperately bored) I get lower fps for some reason, but oh well.
  5. leadpill42

    leadpill42 TS Rookie

    I agree with him.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.