TechSpot

ICS does not work winXP

By jamiecolin
Jul 19, 2006
  1. hello

    i have 2 pcs both running windows XP home edition

    the host computer has 2 network adaptors and the cable moden is connected by USB into the back of the computer

    1 network adaptor has the cable plugged in

    the other has nothing and there is no conflict between the network cards

    The client computer has one network card

    I have no hub or router

    the computers are connected by a ethernet cable directly into the network cards

    the host computer has the internet working but on the client computer the internet does not work.

    file sharing works on both of the computers i can send and receive files

    i have run the network wizard though many times on both pcs and i have restarted i have read though lots of tutorials and other sites but i cannot get the internet to work on the client computer. i have got them both running together before please help ihave wasted days trying to get this to work.

    thanks jamie
     
  2. dazzer9535

    dazzer9535 Banned Posts: 117

    If you have Zonealarm free it doesnt support ICS
     
  3. jobeard

    jobeard TS Ambassador Posts: 9,341   +622

    (A) tells you the host is ok and (B) says all hardware is ok on both.

    With the cable modem, you really should opt for a low cost router --
    you would be much happier with it AND it adds an extra layer of protection (ie: NAT).

    the issue is the IP configuration. being directly connected to the
    modem, you will have a public IP address in the range supported by
    your ISP. The ICS will force the second machine into a private IP,
    something like 192.168.0.x

    the only way to get the client to access the internet is to change the
    client's netmask to 0.0.0.0, which may or may not be set and saved.
     
  4. jamiecolin

    jamiecolin TS Rookie Topic Starter

    ok so the subnet mask is the one i need to change? 255.255.255.0 i have to change that to 0.0.0.0

    ?
     
  5. jobeard

    jobeard TS Ambassador Posts: 9,341   +622

    without a router, that is your best HOPE. if the setting will not stick,
    you are not going to get this to work.
     
  6. Rick

    Rick TechSpot Staff Posts: 4,573   +65

    There's a number of things that could be going wrong here.


    Okay, this is a good start...

    What is this cable connecting to, exactly? Are you referring to the client plugged into the ICS server via network cable?

    That's okay, we can still get ICS working.

    Okay, this is good. But only if you have a cross over cable. Typically, regular 'straight through' network cables will not work like this... Depending on the network equipment of course.

    This means your network is indeed working. You must have a cross over cable or your equipment works fine with a straight through. So this is good.

    ICS shares the Internet connection. Your ICS server computer or 'host' becomes 192.168.0.1 and it now acts as a gateway to your Internet connection.

    Unfortunately, ICS does not also include a DHCP server where you can get your routing information automatically. So everything needs to be done manually. Here's how it should be set up.

    The client computer should have the following network settings.

    * Use the following IP address:
    IP: 192.168.0.2 (The last digit can vary, up until 254, but it cannot be 1. '2' should work fine)
    Subnet: 255.255.255.0
    Default Gateway: 192.168.0.1

    *Use the following DNS Server addresses
    Preferred DNS: 192.168.0.1
     
  7. jamiecolin

    jamiecolin TS Rookie Topic Starter

    i have tryed that previously and i have not been able to get the internet to work. :( i will try it again just in case
     
  8. jamiecolin

    jamiecolin TS Rookie Topic Starter

    I have just tryed it and it has not worked is there anythink else that could be creating a problem? thank you for your help.
     
  9. Rick

    Rick TechSpot Staff Posts: 4,573   +65

    Because we know you're network works, we should investigate your Internet connectivity specifically.

    Ping your ICS host
    Have you tried using the ping command in the Windows terminal? Start > Run > Type cmd and press OK. Type ping 192.168.0.1 to verify you can establish network connectivity to your ICS host.

    Ping a website
    If the ping is successful (You'll get a 'reply'), attempt to ping an external address, such as ping google.com

    Disable firewalls
    If the ping to your ICS host address is unsuccessful, then make sure the address and subnet is set up properly with your ICS host. 192.168.0.1 and 255.255.255.0 are the default values. If the values are correct, a firewall could be blocking ICS traffic. Disable any firewalls on your host and client such as Norton Internet Security, McAfee or Zonealarm etc... As well as the XP firewall. Here's a quick list of firewall disable routines. http://help.expedient.com/general/disable_firewall.shtml

    Client issues
    If the ping is successful for both your ICS host and the external address, then your ICS is working properly. The problem may lie with your browser, Windows or firewall. Again, check how to disable your firewall for both the client and host computers.

    Winsock repair
    Another problem may with your client's winsock. It is possible for it to be altered to allow network traffic, but not Internet. Spyware and Internet security programs can cause issues. If you're using Windows XP SP2, you can issue the command netsh winsock reset in the XP terminal (Start > Run > Type cmd and click OK then type the command above). You can also use this simple utlity to do it: http://www.snapfiles.com/get/winsockxpfix.html
     
  10. jamiecolin

    jamiecolin TS Rookie Topic Starter

    i have the fire wall turned off

    and i will try the winstock thing out.

    is it possible p[rograms like zonealarms aries morphious etc can block ports?
     
  11. kirock

    kirock TS Rookie Posts: 1,221

    Are you sure you have TCP/IP enabled on the client pc? Then again I guess you couldn't set the static IP to 192.168.0.1 and subnet mask if you didn't.
    I have my 2 home PCs linked ICS and I remember a major headache until I turned off the XP firewall on the client machine.
     
  12. Rick

    Rick TechSpot Staff Posts: 4,573   +65

    Zonealarm IS a firewall, and yes... It can block ports. Disable it completely while you try to troubleshoot. Ares & Morphius? No.

    There's not much of a choice in XP. I think if you could actually manage to do this, XP might explode and Microsoft might start distributing Linux.
     
  13. jamiecolin

    jamiecolin TS Rookie Topic Starter

    do i run the program on the client or the host pc
     
  14. jamiecolin

    jamiecolin TS Rookie Topic Starter

    I have just run the winsock program on the host and client computer.

    the host computer ran the program and restarted back into windows i tested the client no internet, then i ran the program on the client and windows froze when i restarted the computer so i had to do a windows restorein safe mode.

    no luck with the program unless i used it wrong. any more possible solutions?

    and thank you once again for helping
     
  15. Rick

    Rick TechSpot Staff Posts: 4,573   +65

    I've never seen that happen before.


    If you were to add the client computer directly to your modem, does it get online?
     
  16. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    I bet its virtual usb nic
    I have yet to get this to work with ics or another network system
    if you can replace with rj45 cat 5e
     
  17. jamiecolin

    jamiecolin TS Rookie Topic Starter

    its a usb modem that i tryed starting with using the usb cable but i had the same problems i have now. then i swapped the usb with a ethernet about 1 week ago but i still have the same problems
     
  18. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    then I would try to delete all instances of nic's all of them in the modem and reg connected machine
    do a cold boot when working with network cards
    on boot
    do run,cmd go to c prompt
    do ipconfig /flushdns
    then start with the main nic get it to do a connect to modem
    this allows modem to give ip address
    make sure other nic is not attached
    after you know there is a connection go to advanced setting
    Allow other network users to connect through this computer's Internet connection.
    add 2nd nic and connect cable to 2nd machine
    run ics wizard on first machine
    ICS can be messed up as with all MS tools
    you may find in long run to get a good router(not cheap)
    or make first machine a router with 3rd party app's
    keep in mind the 2nd cable should be crossover don't switch
    newer nics don't always have to need this
    xp home is the worst for networking
     
  19. jobeard

    jobeard TS Ambassador Posts: 9,341   +622

    it certainly is not sophisticated, but will do simple sharing--
    I am sharing (both ways) with a Mac and a Linux system via Samba
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...