IGI 2 Problem

By olefarte
Apr 20, 2003
Topic Status:
Not open for further replies.
  1. Does anybody else play IGI 2? I'm haveing a problem with the game crashing and freezing to the desktop when I quit the game. When it freezes, if I manage to get it going, (sometimes I have to manually reboot) the desktop goes back to 256 colors. When I reboot, everything's okay again. Could this be a graphics card problem? I've got the latest graphic card drivers and the latest update for the game.


    Edit: If it has anything to do with it, I run AA at 4X and AF at 16X, with v-sync on, and everything else on the card and the game at max.
  2. Tarkus

    Tarkus TechSpot Ambassador Posts: 837

    I played the demo but had no problems with it. ATI driver problem? I've never had any luck with ATI so I'm no judge.
  3. olefarte

    olefarte TechSpot Ambassador Topic Starter Posts: 1,427

    I've never had a problem with any other game with this card. I didn't put it in the other post, but it doesn't do the freeze bit every time. It may be that it's a game problem that needs a patch. That would be a first, wouldn't it.
  4. Killa_j

    Killa_j Newcomer, in training

    I don't think it has any thing to do with your video card. I think that codemasters just needs to fix the singleplayer aspect of this game. I too have had several crashes back to desktop, lock ups, and other weird things happening. But, on the other hand none of these things seem to be happening in the multi-player mode.

    In short, the game is not finished. Too many people have had the same thing happening to them. So, it's not your video card or sound card, it is the game.

    I played the first igi all the way through, the game was good but was missing updates and patches, and most importantly a in game save system. Let's hope that codemasters and innerloop get their act togather and fix this thing before it dies on the vine.
  5. Killa_j

    Killa_j Newcomer, in training

    On a quick trip out to the igi 2 web site they had a fix for the problem. It was all soundblaster cards put the sound config on miles 2d positional. I had mine on eax(which my card is fully capable of) and it seemed to fix the problem.

    I still think that codemasters ought to fix the problem. My card isn't even a soundblaster card and it still crashes. I stand by my earlier statement... fix the game
  6. olefarte

    olefarte TechSpot Ambassador Topic Starter Posts: 1,427

    It's been a while since I finished IGI 2 and I'm not playing it anymore. But, one thing that helped, I found in there knowledge base. It said if you are using EAX, it might cause the game to crash to the desktop, in some cases, but especially midway through level five, I think it was. I could not get it to finish this level without crashing. The fix was to change the audio from EAX to Miles Fast Audio. That solved a lot of my problems, I just forgot to post it back here.

    Edit; I see you beat me to the solution by a few minutes.
  7. Killa_j

    Killa_j Newcomer, in training

    Hehe pretty funny...
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.