TechSpot

In-game Freezing, Only certain games.

By Jeemo
May 25, 2007
  1. Hello.

    I am experiencing a problem where some, but not all games which have some level of 3D graphics accelleration play only for a certain amount of time, and after this it will freeze completely, locking up the mouse, and the sound loops at a very high speed, almost fluidly.

    I have noticed this prolbem most especially on Hitman: Contracts, Civilization IV, and Thief 3. For some games, for example Hitman 2, Stronghold, and most Source-Engine fueled games, this problem was not an issue. I don't know if this is a problem with some kind of graphical rendering, or possibly my hard drive...
    The game will run for as little as 10 minutes, or in some cases as long as 2-3 hours until crashing, this varies a great deal and it is impossible to determine whenabouts it will happen.

    My specs are as follows:

    CPU: Intel Pentium 4 - 2.4Ghz.
    RAM: 768MB DDR2
    Motherboard: ASUS P4S8X-X
    Graphics Card: GeForce 6600GT (128MB)
    Soundcard: C-Media CMI8738
    HDD: Maxxtor 300GB IDE.

    I have had errors with this hard drive before, it tends to make a lot of noise, moreso when running games, and used to spontaneously lock up and reboot with a "CANNOT FIND SYSTEM DISK" which would be solved by me pushing the IDE cable in harder, the latter of the two hasn't happened for quite some time now.

    I suspect it is either my graphics card or my hard drive, or it may even be a result of my cooling fan not being efficeint enough and causing the system to overheat when under strain (such as when running a game).

    I have made sure to download the latest drivers for my Graphics Card, and even Soundcard, and downloaded the latest version of Direct X. As for my motherboard, I am a little stumped as to the method of updating the BIOS, and to be quite frank I'm not even sure that'd have any effect at all.
    Additional help would be much appreciated,
    Thank you.
    - James.
     
  2. sghiznaneck

    sghiznaneck TS Maniac Posts: 544

    I'm not sure about the other games, but I had the same card and problem with Civ IV. Problem was that as the game progresses, it needs more onboard gpu RAM. I swapped out the card for a 256 meg card and never had the problem again. As I said, can't speak for the other games, just Civ IV.
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.