Is installing SP3 over SP2 now still a threat?

By Makingdon
Jun 19, 2010
Topic Status:
Not open for further replies.
  1. Hi guys i have seen many forums and discussions about sp3 over sp2 and most of them said sp3 sucks and has many issues, bugs, etc. and sp2 is overall much better. But i noticed those threads and discussions were very old like 1-2 year old atleast.
    I have a laptop which is very old and from zenith company. It has just 248 RAM and 1.60 GHz. I dont install applications or games on it but just use it roughly for download, work, etc. I have set all graphics off on it even no desktop wallpaper.. which makes it run better.. Its like 1 year almost it had sp3 and i didnt came btwn any issue (prolly cause i dont install apps, games, etc.) But i do updates daily. And there isnt a problem expect one which dosent lets me install windows media player 12 over 11, No its not pirated.
    Now i m using a desktop which got 2 GB RAM internally but outside it shows 1.47 which means some is used by graphic card or something? And it runs at 2.80 GHz, Intel(R) Pentium(R) D CPU.
    It has SP2 but it dosent runs so.. well. On that old laptop my online game which is "Dofus" runs very nice on it than this desktop. It maybe that dofus runs better on laptop? cause i ran it on other desktop too but it always ran better on laptops... no matter what speed of net.
    So i m confused if Sp3 is now stable so i can install and play many games without any bug or lag?

    Please tell me ur fresh opinions (i mean ur new opinions if b4 it was different).
  2. ravisunny2

    ravisunny2 TS Ambassador Posts: 2,048   +8

    SP3 is safe, and recommended.
  3. Makingdon

    Makingdon Newcomer, in training Topic Starter

    Oh yes,

    Ya its safe definately cause even my dad's laptop has it which got 3 GB RAM, 1.60 GHz, etc. But gah when i go to install it ... It completes half but then it closes and a message pops up saying "the file specified was not found" ;-; and then it tells to back some files as they were and reboots... After reboot it says " Your system has been partially updated. Some functions may not work properly." Holy crap i was ><''. In system's properties it still shows Service Pack 2. Can somebody help me now?
  4. superty12

    superty12 TechSpot Enthusiast Posts: 432

  5. Makingdon

    Makingdon Newcomer, in training Topic Starter

    Sorry i wasnt able to be on net for a bit of days... the windows xp sp3 which i downloaded was true and it worked all well after i did it in safe mode. Thanks for all ur replies.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.