TechSpot

Keyboard, characters mixed up (NOT a hardware problem)

By gobraff98
Jan 29, 2005
Topic Status:
Not open for further replies.
  1. When I Type certain sybols on my keyboard, incorrect ones appear.

    -THERE IS NOTHING WRONG WITH MY KEYBOARD!! I have tried several...
    -I have the same problem on another older computer. I had it refurbised with Win98SE and ever since it has had the problem. I also had this computer refurbished with its existing win98se and same problem occured.
    -I am not alone, last time I browsed the net about this prob, I found other forum entries describing exactlythe same problem.

    Here is a list of some of the incorrect keys:
    -the button left of one and above tab with sift on: does that curly line on the true hash key
    -This is the most annoying: The speech mark " and the @ are mixed up: to type a " I have to press @.
    The sterling symbol is impossible to get, it types a #. when I type a # it types a \
     
  2. Nodsu

    Nodsu TS Rookie Posts: 9,431

    You have set the keyboard layout incorrectly. Go to control panel, regional options and set the keyboard layout to match your kayboard.

    Also, check the system tray for the language bar. If you see some two letters there like EN or FR try clicking it and choosing another language.
     
  3. gobraff98

    gobraff98 TS Rookie Topic Starter

    That didn't help but Problem Solved Thanks.

    Keyboard language was set to English United States 101, I am in England and so blah blah........................................thanks anyway
     
  4. spingk

    spingk TS Rookie

    Download Key Tweak (Search google) and remap the keys that are giving you problems. Because it is not a hardware problem your keyboard most likely got remapped somehow.

    -Spingk
     
  5. flgllm1

    flgllm1 TS Rookie

    Could be Microsoft Office

    Check whether ctfmon is running. Alt+Shift gets the keyboard into weird states sometimes with that part of Office running. See MSFT KB Article ID 282599 and 870774

     
  6. cyrixs

    cyrixs TS Rookie

    hey braff, I just had a similar problem that u had, its a problem with the OS you are right about that. Now I checked regional / time settings, nothing. Also checked to re-install drivers, rip root hubs, nothing. Try booting it into safemode and go on the basic administrator account and see if the characters are correct, if they are just restore the pc back to a date before the problem happened, use a different profile or reformat. I know theres a simple solution for it, but system restore in the xp help and support worked for me so I'm not going to go digging for answers.
     
  7. gredyck

    gredyck TS Rookie

    I had the same kind of problem. After looking at the articles referenced in a previous replay above I discovered that my keyboard will get toggled between an alternate input state with the Alt-Shift key sequence. I can toggle it back to the normal state pressing the “Alt-Shift“ key sequence (and back again). So my problem is solved but if you hear about it from someone else, you can let them know about this fix (trick, feature???).

    Hope this fixes your problem.
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.