Laptop Compaq Armada 4120 and graphic/color problems.

By Marc
Jul 19, 2005
  1. Hi,

    Since a other major problem of mine was solved on this forum, I've decided to bug you guys with another problem im having. This time its about a laptop (Compaq Armada 4120, im not entirely sure of the specs, but its pretty old, probably a pentium 1, if that's even possible) and having issues playing games/running programs. For example, in order to play older games you'd have to run a programme called DOSbox, but when I try to run said programme, it says something along the lines - Error, Can't set color palette-, also when I try to play another game called Beetle Ju, it gives me the message "Failed to initialize graphic system"

    Also, I've noticed that when I do the right click > properties screen, the colors are set to 256-colors without a possibilty to raise it to 16/32 bit which is usually was (if im correct) And I've always thought that it was supposed to be at least at 16-bits.

    So my guess was that I had to install new video/display drivers because it could have been accidentally erased. So I did.. ( Cirrus Logic 7548 1.40M PCI (Cirrus) but when I had downloaded it, I couldnt even get the file to open or install anything, it did nothing at all.. So I probably have to put it somewhere in the Windows folder but im not that much of a computer expert to know where exactly.

    And another thing worthmentioning is the fact that the upper half of the screen is filled with a barcode like pattern. I once got rid of this problem by installing Windows Service pack 1 but after I shut the computer down the barcode came back.

    I hope anyone can give me suggestions on how to fix this problem, my experiences with this board are very positive so im sure some helpfull hints and tips will come out of this, Thanks in advance!
  2. zephead

    zephead TechSpot Paladin Posts: 1,569

    what operating, service pack, and dos games are your running?
  3. Marc

    Marc TS Rookie Topic Starter

    Oops, forgot to mention the OS is Windows 98, and I was trying to run the game Beetle Ju. (windows game) and DOSbox (a windows programme you need in order to play older DOS games) And Service pack 1.0. (It didnt even have one installed untill I downloaded it today.)
  4. Marc

    Marc TS Rookie Topic Starter

    Sorry about bumping this thread but I just found out that when I type DXdiag in Start > Execute, and then look at the System tab, it says that I dont got a BIOS installed it just says - BIOS - n/a. Also the computer specs are Intel Pentium 120 mhz.

    If anyone could tell me where to get BIOS drivers for this computer system, I would be most gratefull.
  5. nucleardreams

    nucleardreams TS Rookie Posts: 68

    Compaq Armada 4120 specs.
    8-16MB RAM soldered on the mainboard.
    2x memory expansion slots, combined max. 80MB RAM.
    810 to 1400MB hard drive
    Display with max. 256 colors and 800x600 resolution.

    Compaq Armada 4120 does not have a BIOS chip, the BIOS is a software installed in a separate partition.

    If you want I can send you, per email, the Armada 4100 series manual. It has alot of trouble shooting guides that may be of help. The manual is in PDF format and is about 1.2MB.
  6. Marc

    Marc TS Rookie Topic Starter

    Ok, so the BIOS chip isnt necessarily the problem here, I also saw in the DXdiag that the computer didnt had a Direct3d driver, I dont know if this has anything to do with the current graphical problems but just thought I'd mention it.

    BTW, I'd like to see that 4100 series manual you mentioned. Ill pm you my email adress. Thanks!
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...