TechSpot

Local Area Network (LAN) connection isnt showing up in connections

By mda13336
Dec 11, 2007
Topic Status:
Not open for further replies.
  1. Hi thanks for looking,
    I have just recently reinstalled windows. When I plug in the lan cable, no LAN connection comes up. I have never had this problem before and usually just doing this will allow me to have internet.
    Whats wrong? How can I fix?

    Thanks
  2. Fragrant Coit

    Fragrant Coit TS Maniac Posts: 579

    It needs a Driver. You'll need to visit the Motherboard Manufacturers website & download the driver for your model board.

    Before you go there, look in Device Manager {control panel / system /hardware} and see if anything else has an exclamation mark - they'll require drivers too!
  3. mda13336

    mda13336 TS Rookie Topic Starter

    Awesome will give that a try. How do I find out what motherboard it is?
  4. Fragrant Coit

    Fragrant Coit TS Maniac Posts: 579

    Either rip the side off the Case and eyeball it, or use a tool like this:
    http://www.cpuid.com/pcwizard.php

    It'll tell you more about your PC than you ever wanted to know!
  5. mda13336

    mda13336 TS Rookie Topic Starter

    Wow that PC wizard really is amazing! Thanks for that!!!!

    TOTALLY AWESOME
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.