Login prompt in RH7.2 in text, not graphical...

By Vehementi
Sep 25, 2002
Topic Status:
Not open for further replies.
  1. The whole bootup goes normally, GRUB boots Linux fine, but when it gets all done loading, when instead there's a text login prompt than the normal graphical one...

    that would be just fine, but, no, it isn't.

    at localhost Login I enter 'root' then hit enter...

    Password:

    Okay this is normal, but oh wait! I can't type anything in the pw field. Only responsive keys are enter. Well, I press enter, and type in my password, but, login failed! Hmm.

    Uhh, help? :D
  2. Phantasm66

    Phantasm66 Newcomer, in training Posts: 6,504

    You are typing in the wrong root password. Here is how to fix it.

    Reboot your machine and start LILO (pick from boot menu if that's the way you did it.) You should see the big red screen with the menu to choose between Linux and DOS if dual booting.

    An option should say "Press Control and X for Text Mode" or something like that, do so.

    You should get a prompt that looks like this BOOT:

    Type "linux single" or "linux 1" and press return.

    This will start linux in single user mode. You will eventually reach a command prompt which you will not need to enter username and password for, which will have root priviledges.

    type this:

    passwd root

    then choose a new root password and remember it this time
  3. Mictlantecuhtli

    Mictlantecuhtli TechSpot Evangelist Posts: 4,916   +9

    I thought textmode is the 'normal' one ;)

    In textmode, the keys are responsive but for security reasons, you don't see anything, not even stars.
  4. Phantasm66

    Phantasm66 Newcomer, in training Posts: 6,504

    If you want to switch to a graphical login (which I don't like) then either

    a) run Xconfigurator from the text screen before running "Xstart" and after resolution config, etc, the last option is whether or not you want a graphical login, choose whatever,

    or the geek's way which I would be more impressed if you did:

    b)open the config file /etc/inittab in a text editor, look to this section near the beginning:

    #
    # inittab This file describes how the INIT process should set up
    # the system in a certain run-level.
    #
    # Author: Miquel van Smoorenburg, <miquels@drinkel.nl.mugnet.org>
    # Modified for RHS Linux by Marc Ewing and Donnie Barnes
    #

    # Default runlevel. The runlevels used by RHS are:
    # 0 - halt (Do NOT set initdefault to this)
    # 1 - Single user mode
    # 2 - Multiuser, without NFS (The same as 3, if you do not have networking)
    # 3 - Full multiuser mode
    # 4 - unused
    # 5 - X11
    # 6 - reboot (Do NOT set initdefault to this)
    #
    id:3:initdefault:

    if you edit the id:3:initdefault: section, 3 is the text login screen and 5 is the graphical. make sure to save your changes and then reboot.

    don't choose 6 like it say, or immediately upon booting, your system will reboot. 3 and 5 are the only real options you should be considering under normal circumstances.
  5. Vehementi

    Vehementi TechSpot Paladin Topic Starter Posts: 3,199

    Ok. So, I reinstall Linux. Be sure to select Graphical Login in XConfig, actually it was by default...

    So everything goes smooth, and I'm back where I was. I enter the proper password, and then it gives me [root@localhost root]#
    Or something of that nature. Gee, thanks, can I boot to Linux now? :blush:
  6. Vehementi

    Vehementi TechSpot Paladin Topic Starter Posts: 3,199

    Oddly enough, the last time I installed Linux, I selected KDE as my default desktop environment, but this time I left it on GNOME...

    Could that be it?
  7. Phantasm66

    Phantasm66 Newcomer, in training Posts: 6,504

    Who the Hell said anything about reinstalling Linux? I said re-run Xconfigurator to reconfigure X Windows. Don't reinstall every time you have a small problem or you will never learn anything new.

    Are you booting from your HDD or from a floppy?
  8. Phantasm66

    Phantasm66 Newcomer, in training Posts: 6,504

    The [root@localhost root]# thing IS Linux!

    In fact, I believe that Linux is actually the kernel, in the strickest sense.

    The GUI is X Windows.

    Anyway, are you using a boot floppy? And why did you reinstall, and not follow the simple instructions that I posted?


    I thought that the b) option was maybe a little out of your depth but the a) one was simple. If you had needed clarification about anything then you could have posted back here.


    I don't mean to sound harsh, its easy for me as someone who has done this often to preach. Certainly, someone was showing me assembly language last night, and its fairly tricky stuff I think, but to him it was easy and he certainly never lost it with me or patronised me when I made what to him must be a simple stupid mistake. But please do take the time tor read people's replies and post back here if you have any questions about any instructions that you are given. You will learn more which is what I and others are trying to achieve.
  9. Elcarion

    Elcarion TechSpot Paladin Posts: 188

    Option c)

    For the record you can also type "init 5" at the Linux prompt to change to GUI mode. This will update /etc/inittab and start X.
    Then again, so much for simple instructions!
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.