Mobility Radeon 9000 and Final Fantasy XI

By s202sti
Dec 6, 2004
Topic Status:
Not open for further replies.
  1. I recently got a toshiba A70-249 with an ATi Mobility Radeon 9000. I am using it for work but i have a game that I would like to play on it called Final Fantasy XI. The graphics look nice but it is not smooth at all. When i first tryed the game it didnt run that smooth using the default video drivers that came with it, then i upgrade to the omega drivers and it still didnt do the trick. I also upgraded the system memory to 768 (accually 640 because I have the UMA Frame Buffer set to 128). I downloaded some demos from Ati and they dont run that smooth either, i have all the setting set to the lowest on the 9000 (after trying many different in and out of game setting combos) and it still doesnt make much of a difference. what can i do (settings or otherwise) to make the game run more smooth. HELP

    PS. this is an online game and i understand lag is a factor but not as much of a factor as the problem i am having.
  2. LNCPapa

    LNCPapa TS Special Forces Posts: 4,271   +257

    Biggest thing I've seen to cause bad performance in FFXI is the weather effects. Have you tried logging and and then disabling them? That's the only thing I can think of specific to FFXI
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.