TechSpot

Mouse problems

By Rizz
Sep 16, 2007
  1. Sorry if this is in the wrong sectoin, im currently trying to navigate the web without a mouse.

    So my problem is, my mouse isn't working. More specifically, the left click and right click buttons aren't working. I can move the mouse, but the two buttons aren't working. I've tried replugging the mouse and cleaning the ball but nothing seems to work. ANy ideas.

    BTW, this happened when i turned the mains off from my PC as i was moving it.

    EDIT: The mous is a Microsoft PS/2
     
  2. pdyckman@comcas

    pdyckman@comcas TS Rookie Posts: 718

    Why don't you try another mouse? This is a simple offer. Before it get's more complex...pleeze try another mouse
     
  3. raybay

    raybay TS Evangelist Posts: 10,716   +6

    If a PS/2 mouse, check the pins on the mouse and the sockets in the PS/2 port. Sometimes pins get bent, sometimes dirt gets into the socket buggaring up the connection. Otherwise, PS/2 mouse is remarkably rugged unless it gone water on it or suffered a hard impact. You can use canned air such as dust off to clean it.
    If it is a wireless mouse, through it out. They typicall have the highest failure rate of any computer hardware.
    If it is a usb mouse, check the usb plug and change to another usb socket.
    Mouse hardware on the computer (other than the bent pins) will rarely fail.

    A new mouse can be had at Wal-Mart, Best Buy, Dollar Stores, Walgreens, and Circuit City for $6.95. Good USB ones by Logitech are $29.95 Salvation Army, HabiStore, White Elephant, and other such rehabilitation centers usually sell for $1.00 to $2.00.
     
  4. Rizz

    Rizz TS Rookie Topic Starter Posts: 32

    Unfortunately, i don't have another mouse available to try. But im sure my mouse should be working fine. I haven't dropped it and its under 2 years old.

    Ive tried changing the primary functions, iv checked the double click speed. Nothing seems to work


    EDIT: Also, the pins are fine. Im convinced that this has something to do with settings being reset when i turned the mains off. I've tried using the troubleshooting program on my computer...but i can't click on the options that im supposed to 'click'. Im finding this situation very streefull/funny XD
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.