Msi Pc54g2

By Michael88
Jun 23, 2005
  1. Today I bought an MSI PC54G2 Wireless LAN card, hoping it would work in my new coustom built system. However I have previously tried (On a different system) exactly SIX other brands of network cards, none, not one have worked. I can't get it to connect. Can anybody help? I have no idea what the heck is going on. I've got an entirely new system and it STILL won't work.

    Intel Celeron 2.6
    Lemel 512 RAM
    420w PSU
    ASUS P4S800-mx mobo
    LG DVD burner (the one in the review section of this site)
    80GB Western Digital HDD (8MB cache)
    Windows XP Pro (clean installation, no service packs yet - I do have SP2 on a CD)

    *edit* I just downloaded and installed the latest drivers and utilities from MSI. Now It actually picks up a network but does the same thing as each of the previous 6 I have tried - a no name network, sometimes it WILL ocnnect but the signal is Very Low (I'm about 6 metres from the router!) and stay on for 1 second only.

    Please help, somebody!
    So desperate.

  2. Michael88

    Michael88 TS Rookie Topic Starter

    Does anybody know how I can fix it? Pleeease? *is desperate*
  3. Michael88

    Michael88 TS Rookie Topic Starter


    Thankyou, everybody, for your support on this issue.

    Since I last posted, I found how to fix the problem and now I can gte my network working fine!

    What I'm trying to say, is, PM me if you have the same problem and I'll see if I can help.

  4. Greg_kot

    Greg_kot TS Rookie

    I have exactly the same problem, my MSI PC54G2 disconnects every once in a while by itself then reconnects again later. Anybody know why this is?
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...