TechSpot

Multimedia Audio Controller problem

By rosswale17
Mar 22, 2007
  1. Recently, my old hard drive crashed, so i got a new one, and I re-installed windows on it and transferred my files over, and everything works fine except the sound.. iTunes and Windows Media Player both tell me there is a problem with my sound device.

    My computer is just about 3 years old now.. I don't know what kind of motherboard i have, just that the sound card is integrated. When i opened up the case, the only words on it are "SIS" with some other numbers under it.. there is another green thing that says "Gigabyte 8x AGP" and another thing with a picture of a crab on it that looks like the "soundman" file picture.

    I've tried Genius Sound Maker and the SIS7018 driver off of the site but neither worked.

    I hope i've given enough information and somebody knows how to help me =\

    thankssssss
     
  2. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Hello and welcome to Techspot.

    Download the free Everest programme, it may enable you to find out what mobo you have.

    Once you know what mobo you have, go to the mobo manufacturers website and download and install the correct sound drivers for your model.

    Regards Howard :wave: :wave:
     
  3. rosswale17

    rosswale17 TS Rookie Topic Starter

    Worked perfectly, thanks a lot man.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...