Multimedia Audio Missing

By franko
Dec 18, 2007
  1. Hello I am New!
    New here and new at trying to do my own work on the computer.I just reinstall windows xp, and now I can't get back in to my Comcast web site I went into device manage and it shows I have 3 explantion charters in yellow,
    As Multidiamedia audio controller,PCI simple Communcation controller ,, Video controller {VGA Compatable}

    for any help
  2. Daveskater

    Daveskater Banned Posts: 1,687

    Hello, franko, and welcome to Techspot :wave:

    Please take a moment to read the following threads to make your experience here as enjoyable as possible :)

    Message for all newcomers

    SNGX1275's Guide to making a good post/thread

    The Techspot FAQ

    If you could take a minute to fill in some of your profile information that would be helpful to all members of the forum :)
    Knowing someone's location in the world can be extremely helpful, even if you just put a country.

    Also remember to post any problems or questions that you have in the appropriate forums

    With regards to your problem, you need to install drivers again.

    The drivers for the audio controller will be on the CD that came with your motherboard.

    PCI Simple Communication Controller - think of what PCI devices yo have and if one of them could be this one, to me it sounds as though it could be a network card but I don't know what PCI devices you have.

    Video Controller is your graphics card. Go to the nVidia or ATI website (depending on what card you have) and download and install the latest drivers for your card.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...