My Dell Dimension 4550 won't power up. New P/S, power cord, etc. doesn't help.?

By gbsdirect
Jan 8, 2008
Topic Status:
Not open for further replies.
  1. The system's fan was very loud so I put in a new power supply and then everything booted up fine. Unfortunately, that didn't solve the problem. It was the Motherboard fan making all the noise.

    So, I put the old power supply back in and now the system doesn't power up at all. I checked all connections & I replaced the power cord and tried a different electrical outlet.

    I even put the new P/S back in and nothing changed. It still doesn't power up. It's dead!

    Any suggestions?
  2. kimsland

    kimsland Ex-TechSpotter Posts: 18,353

    Do you mean the CPU fan ?
    If so then I wonder if the CPU has been cooked

    I would start by dispersing all internal voltage.
    Detach the power cord
    Press the power button in for 20 seconds
    Re=attach the power cord
    Try again

    If it didn't fix then remove all addons, usb devices really anything attached (except screen and keyboard and power cord)
    And try again

    If it didn't fix then, confirm all internal connections are secure (even detach the dvd drive{s}

    If it didn't fix then try disconnecting all fans (what !) for about 10 secs (turning on) I once had a fan of all things, that stopped my computer from turning on (unbelievable, I know)

    Lastly, check the CPU for heat damage !
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.