TechSpot

My Razer Copperhead Died!! HELP!! No support from Razer!

By EG1
Apr 7, 2006
  1. Need some help from you all.

    I bought a Copperhead back in October from EBay . It was brand new and sealed. I really loved this mouse... This weekend it died. :dead: It still lights up and the buttons seem to work but the mouse does not move. I found a Knowledge Base item on Razer's website that said if this happens call tech support. I did and they said that they would not RMA it because I bought it on EBay. The darn thing cost me $95.00. Is there anything I can do to fix it? As anybody else have this problem?

    Thanks
    EG1
     
  2. CrossFire851

    CrossFire851 TS Rookie Posts: 766

    Try it on another computer to see if it works, there maybe a driver conflict.

    (I have one, there drivers aren't the most reliable)
     
  3. EG1

    EG1 TS Rookie Topic Starter

    Thanks for the quick reply.

    I tried that with my laptop. I even tried reloading the firmware. That didn't work either.
    EG1
     
  4. CrossFire851

    CrossFire851 TS Rookie Posts: 766

    Buy one at you're local computer retail store then return the broke one. Trust this is what I do when I lose the reseat.



    (Lol, don't know how to spell reseat right lol)
     
  5. EG1

    EG1 TS Rookie Topic Starter

    I thought about doing that but... it dos not seem right (bad carma)

    I e-mailed the guy that sold it to me and he said that he bought it best buy but he didn't have the receipt. I foward this to Razer and still no RMA.

    On one of Razer's forums I wound that there iis a lot of people who bought the blue cooperhead having the same issue.

    I guess its time for small claims law suit!
    EG1
     
  6. FiatLux

    FiatLux TS Rookie

    Fail

    You both fail.

    First of all, I believe it is spelled : receipt

    and second of all, I KNOW it's spelled : KARMA not CARMA !!!!

    dolts...

    To get back on topic however, have you ever thought of asking someone to post a picture of their receipt up here for you? I have a broken Copperhead as well and that's what I wish someone would do....

    *hint hint* all you readers of this post...........
    :wave:
     
  7. tweakboy

    tweakboy TS Guru Posts: 467

    Why in Gods name did you pay 95 dollars for that mouse on ebay ? You live out of country or something ?

    You shouldn't have payed more then 70 shipped to door brand new.

    The problem your having is possibly not a dead mouse. You say buttons works and it lights up but the cursor doesn't move.

    What I would try is.

    Uninstall razer drivers

    take out mouse from usb and put it in another usb port.

    Then boot up and see if it moves. Either way your next step is to install the latest drivers from razer support.

    If still fails then you have yourself a dead 95 dollar mouse ,, sighs!!!
     
  8. Acclamator

    Acclamator TS Rookie Posts: 261

    You guys do realize this is a pretty old thread right?
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...