TechSpot

My screen won't display anything.

By natkay2603
Nov 22, 2007
  1. Hi Guys,
    my screen won't display anything. I have checked the monitor an cable and have tried a new graphics card. The motherboard is new so it should work fine. The Pc powers up (fans etc come on). What could it be?
     
  2. PimpPanther

    PimpPanther TS Rookie Posts: 39

    im thinking either the monitor itself is broken
    or
    you're drivers are wrong/out of date


    have you tried with another monitor?
     
  3. natkay2603

    natkay2603 TS Rookie Topic Starter

    yes i have checked the monitor on another PC. i don't think it is the drivers because it won't even display the BIOS.
     
  4. Fragrant Coit

    Fragrant Coit TS Guru Posts: 363

    if you press the menu button, does it disply that?
     
  5. PimpPanther

    PimpPanther TS Rookie Posts: 39

    i didnt say check the monitor on another pc

    i said check your pc with another monitor

    see if the computer wont work with any monitor(i assume youre using another computer to be on here)
     
  6. natkay2603

    natkay2603 TS Rookie Topic Starter

    Oh right sorry. Ok i have now tried another monitor and that doesn't work either.

    Yes the menu button works.
     
  7. PimpPanther

    PimpPanther TS Rookie Posts: 39

    so your monitor is not your problem

    have you installed any new graphics card?
    if your running the montior through a new card, its entirley possible that the card isnt fit in properly(guess why i know that)


    if another monitor doesnt work, chances are something is physically wrong with the comp
     
  8. Blind Dragon

    Blind Dragon TS Evangelist Posts: 3,908

    Does the new motherboard have integrated graphics?
     
  9. natkay2603

    natkay2603 TS Rookie Topic Starter

    yes it has intergrated graphics, but i have also tried a graphics card. neither work.
     
  10. Fragrant Coit

    Fragrant Coit TS Guru Posts: 363

    The Onboard won't work whilst a Video Card is installed.

    As the Monitor displays the Menu, I'd say the Card is faulty, but remove it, then try your Onboard.
     
  11. natkay2603

    natkay2603 TS Rookie Topic Starter

    I have already tried the onboard without the new card installed. the onboard does't work either.
     
  12. natkay2603

    natkay2603 TS Rookie Topic Starter

    does anyone have any ideas? could it be a faulty motherboard or processor?
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...