My Sony Vaio is losing it!!!

By olleander
Apr 18, 2007
Topic Status:
Not open for further replies.
  1. Okay, so I have this Sony Vaio laptop. Recently (for the past month or so), the letter o doesn't show up when I press it on my keyboard. However when I press the letter e, o follows it and would not stop going. Also sometimes when I turn my laptop on, I hear this high pitched sound that would not stop unless I press a button on the keyboard. Another thing is that the on-screen keyboard works perfectly and so I decided to uninstall and reinstall my keyboard hardware but that did not work. So, before I spend a fortune seeing a technician here, can anybody tell me what to do?
    (Note: I'm obviously not using my laptop right now).
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 20,676   +152

    What is the model number of this Vaio? How old is it?
  3. beef_jerky4104

    beef_jerky4104 Banned Posts: 1,094

    You may have to ship it back to the manufacture.
  4. olleander

    olleander Newcomer, in training Topic Starter

    It's a VGN-FE600 and I bought it from the Sony online store in August 2006.
  5. Tmagic650

    Tmagic650 TS Ambassador Posts: 20,676   +152

    It is still under warranty. Call Sony support and find out where their nearest warranty repair station is
  6. olleander

    olleander Newcomer, in training Topic Starter

    True! I'll do that tomorrow, thanks!
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.