TechSpot

My Toshiba Laptop won't startup

By jaya4plra
Jul 22, 2008
Topic Status:
Not open for further replies.
  1. I have a Toshiba Satellite Laptop 2805-S301 with windows Millennium Edition. It was having problems connecting to the internet due an abrupt loss of an IP address. I tried to restore the address, but did not have any success. Now the system won't even turn on, or even go to safe mode. It just go to a blank screen for several minute's then gives the error: Scandskw has caused an error in COMCTL32.DLL.and won't start up! I have tried to contact Toshiba but the warranty expired, and Microsoft says it does not give support with windows ME. Can someone please help!!!!
  2. raybay

    raybay TS Evangelist Posts: 10,716   +6

    You can fix it, but it will be costly.
    Your hard drive is likely bad, but new ones are relatively inexpenisve at www.directron.com, www.zipzoomfly.com, www.newegg.com, www.outpost.com and others.

    Replace WMe with W98SE, or W2K, or WXP... Max out the memory to see if it will give you more than 512 MB to handle WXP.
    The model number you gave, Satellite 2805-S301, does not show up in my book. Are you certain it is correct? Give us the numbers off the bottom of the computer.

    Max out the memory. Replace the hard drive. Get a copy of Windows XP someplace, download the Toshiba drivers, and you should be on your way to recovery.
  3. jaya4plra

    jaya4plra TS Rookie Topic Starter

    TOSHIBA
    2805-s301 system unit
    p650, 14TX. 128M.10.DVD/M/L
    part NO. P5280U-ELCL0H
    serial NO. 90961447U -1
    DC15V 4.0A

    Microsoft Windows Millennium Edition
    product key:
    C8KH7-D8J7V-6R8BC-8KGR2-JKMBM
    00029-016-692-740
    Microsoft X05-59722

    Thanks!
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.