my usb does not work

By nayeem39
Nov 13, 2007
  1. my usb does not work


    I have flash usb stick, from the company cruzer micro/SanDisk. The trouble I have is it Doesn't show on my computer.

    It works at school and it comes up as removable disk. But at home it doesn't come up as removable disk or anything. It also works at my antys house. So it can't be my memory sticks fault. At the time it can't be the computers fault because my other one works as well as all other usb connections. I tried it going to computer management and disk management and this thing come ups hand and i cant click it. But i wnet to this other thing wich is also located in computer management and it came up as cruzer micro and then it says reinstall it so i clicked that and the it says it cant the wizard cnt find the thing and then i went to advanced. This were you get to chose the pecific thing and i clicked all media and i also clicked search pecific folder and it says usb cable and then when i clicked ok it and it says it can't do it. Then today i tried it on my dads account and it came up as removable disk(f. But when i clicked it says no disk found.

    i will be greatful if u can help because it is affecting my gcse double ict.
    Thank u .

    Post moved to it`s own thread, rather than leaving it in a totally unrelated thread.
  2. Rik

    Rik Banned Posts: 3,814

    What windows version are you using?
  3. nayeem39

    nayeem39 TS Rookie Topic Starter

    i am using windows xp

    i am using windows xp and the meory and i have intel pentium 4 .
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...