TechSpot

Need help displaying autoplay...

By chaos450
Nov 4, 2002
Topic Status:
Not open for further replies.
  1. I just noticed this problem a couple of days ago... my computer no longer autoplays CDs. Instead, it pops up a Explorer windows showing the contents of the root of the CD. I don't know what the hell is wrong, and trying to re-enable Autoplay through Device Manager is useless, as the Settings tab in my CD drive's property window is not there. I've tried updating the firmware of my CD writer and my DVD drive, but to no avail. Is my copy of Windows screwed or something? (Also, I have the problem of my DVD drive now being listed as "CD Drive" in My Computer. Is that related to my problem?) Can somebody help me out with my problem? Thanks.
  2. Nodsu

    Nodsu TS Rookie Posts: 9,431

    Try removing the CD/DVD devices in Device Manager. You may want to remove IDE controllers too. Reboot and let Windows install fresh drivers for everything. Even better, download newest drivers for chipset (maybe drives doo) and force Windows to install these.
  3. Rick

    Rick TechSpot Staff Posts: 6,304   +52 Staff Member

  4. StormBringer

    StormBringer TS Rookie Posts: 2,871

    I was about to direct you to Winguides(fromerly regedit.com) as well, but Rick beat me to it. Anyway, there are ways to enable it through registry, I believe that some tweaking utilities have this ability as well.

    No reason to go reinstalling and updating drivers and such unless you have to. Updating drivers when you don't need to is almost as big a cause of problems as outdated drivers are.
  5. Phantasm66

    Phantasm66 TS Rookie Posts: 6,504   +6

    your quickest route is an installation of tweakUI which is available from microsoft, the change you want its under the paranoia tab:

    http://www.microsoft.com/ntworkstation/downloads/PowerToys/Networking/NTTweakUI.asp

    It doesn't mention working in win-xp but it does. You right click the .inf file (one of several that it unpacks) and then select install. Its then found in control panel.

    In 99 per cent of cases this is a registry related problems and not a driver or firmware issue, and is resolvable through tweak UI.

    if autoplay seems to be enabled in the paranoia tab, untick it, reboot, and then tick it again, reboot.
  6. StormBringer

    StormBringer TS Rookie Posts: 2,871

    That is the incorrect version of TweakUI for XP. That is 1.33, The version you want is 2.00.1.0 Find it and the rest of the Power Toys here
  7. Rick

    Rick TechSpot Staff Posts: 6,304   +52 Staff Member

    There IS a version of TweakUI for Windows XP... Microsoft quickly discontinued it though, from what I heard.
  8. StormBringer

    StormBringer TS Rookie Posts: 2,871

    Actually Rick, the link I posted above is the version for XP, at the MS site.
  9. chaos450

    chaos450 TS Rookie Topic Starter

    Dangit, TweakUI doesn't work...

    I have TweakUI downloaded, but interestingly enough, going to the "Autoplay" section indicates Autoplay is on, even though the function is still pooched. :dead: I also have Tweak-XP, and trying to re-enable it there is just as futile :mad: .

    I tried something out, and found the Autoplay functions actually works in a way...but only if a data CD is in the drive when the computer starts (if the drive is empty or had an audio CD, this fix doesn't work). But trying to insert another CD (other than the one in the drive when the comp starts) gives me a message that the Autoplay demands the files from the CD of that was previously in the drive, thus rendering this fix broken as well as useless... :confused: Have any of you seen this kind of behavior before?
  10. DatKoolKat

    DatKoolKat TS Rookie

    Same Problem.....

    I am having the same problem with my dvd drive. Did you ever fix it?
  11. Goalie

    Goalie TS Rookie Posts: 703

    I don't at all expect this to work, but something you can give a try:

    Diable autoplay in Media Player and applicable windows sections.
    Reboot (clears out old settings that may cache)
    Re-enable
    Reboot before testing
    Now test.

    This generally works better for programs as opposed to windows components, particularly for programs which cache settings (Outlook and OE come to mind...)

    My ISP's DNS is hosed at the second, else I'd go search MSKB.. I'm sure there's a reg key or nine for autoplay- You might have some conflicting settings.

    Only other thing I can think of would be to search MSKB for a bug fix/hotfix.

    Doubt this will help, but good luck!
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.