Need Help with low FPS issues while playing WoW

By SBoeks14
Jun 12, 2006
Topic Status:
Not open for further replies.
  1. At times while playing WoW I am getting on average 60fps then at other times my frames are running around 15fps and can drop as low as 1-2fps. I just bought a new graphics card and this did not solve my issue can anyone help?

    I am running:

    AMD Sempron 3300+(64bit)
    Windows XP Media Center
    2gb DDR PC3200
    Sapphire ATI x1600pro 256mb 8xagp
    Driver is the newest ATI driver from OmegaDrivers

    I think this should perfrom well can anyone see any reason from this that my FPS run so low at most times in the game.

    Thanks for the help
  2. Rik

    Rik Banned Posts: 4,987

    What psu are you using and what wattage is it?
  3. Shawn2k5

    Shawn2k5 Newcomer, in training Posts: 66

    It depends on where it happens in WoW, if you are entering a large city (Iron Forge) then FPS may drop because your computer has to render those 500+ people in the city. However, if it just does it at random times when you are out fighting somewhere deserted then you may have a problem.
  4. SBoeks14

    SBoeks14 Newcomer, in training Topic Starter

    Thanks for the replies guys,

    I am not sure what PSU is in there I can check that when I get home and let you know. As for the times it does it, it is mainly when I am in major cities when people are around or during raids or when I am in groups.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.